MST Topology Change

Unanswered Question
May 19th, 2009
User Badges:

I have a circular network loop using MST. The switches are connected via dual gigabit fiber in an etherchannel bundle.


I had to re-run fiber connecting 2 of the switches, so I shut down the port-channel interface between them. Now that I have all of the cabling back in place, will there be any interruption of service when I re-enable the etherchannel link?


I understand that MST touts speed as one of its key selling points, but this is an extremely high availability environment and even a few seconds of downtime could be catastrophic.


In my mind, it shouldn't be any different than how MST would operate if a cable were to be removed from a switch, which is something I've tested and worked perfectly. I just can't afford any gotchas here. UDLD is enabled on both switches; aside from that all relevant information should be below.


In short, here is a simple diagram.



A--------B

| |

D--------C


The port channel interface between switch A and D is administratively shut down. When I re-enable it, will it disrupt any traffic?


Here is my configuration:


A:


MST Config:

!

spanning-tree mst configuration

name CLV-Region

revision 10

instance 1 vlan 2-6, 15, 20-23, 30, 40, 50, 100, 200

!

spanning-tree mst 0-2 priority 8192


Interface config:


CLV-MDF-SW-01#sh run int gi1/16

Building configuration...


Current configuration : 311 bytes

!

interface GigabitEthernet1/16

description CLV-IDF2-SW-01 Uplink

switchport trunk encapsulation dot1q

switchport mode trunk

service-policy output autoqos-voip-policy

qos trust cos

auto qos voip trust

tx-queue 3

bandwidth percent 33

priority high

shape percent 33

channel-group 2 mode on

end


CLV-MDF-SW-01#sh run int gi1/17

Building configuration...


Current configuration : 311 bytes

!

interface GigabitEthernet1/17

description CLV-IDF2-SW-01 Uplink

switchport trunk encapsulation dot1q

switchport mode trunk

service-policy output autoqos-voip-policy

qos trust cos

auto qos voip trust

tx-queue 3

bandwidth percent 33

priority high

shape percent 33

channel-group 2 mode on

end


CLV-MDF-SW-01#sh run int po2

Building configuration...


Current configuration : 139 bytes

!

interface Port-channel2

description CLV-IDF2-SW-01 Uplink

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

end


D:


MST Config:


!

spanning-tree mode mst

spanning-tree loopguard default

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

spanning-tree mst configuration

name CLV-Region

revision 10

instance 1 vlan 2-6, 20-23, 30, 40, 100, 200

!

spanning-tree mst 0-2 priority 24576


Interface config:


!

interface GigabitEthernet0/1

description CLV-MDF-SW-01 Uplink

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

priority-queue out

mls qos trust cos

auto qos voip trust

channel-group 1 mode on

end


CLV-IDF2-SW-01#sh run int gi0/2

Building configuration...


Current configuration : 321 bytes

!

interface GigabitEthernet0/2

description CLV-MDF-SW-01 Uplink

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

channel-group 1 mode on

end


CLV-IDF2-SW-01#sh run int po1

Building configuration...


Current configuration : 102 bytes

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

end


All in all it seems like a no brainer, but I'd rather someone with more MST experience comment on this. I've goofed before by adding a VLAN and causing an instance recalculation (outage!) and would rather not have to explain something like that again.


Thanks,


Jason



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 05/19/2009 - 12:33
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jason,

I don't know if it is an error on reporting but the two lists of vlans associated to mst 1 don't match:


you have the same region name, the same rev. number but I see

A:

instance 1 vlan 2-6, 15, 20-23, 30, 40, 50, 100, 200



D:

instance 1 vlan 2-6, 20-23, 30, 40, 100, 200


vlan 50 is missing here so if you connect them they will treat each other as belonging to a different MST region and using CST.


I think you need to make configurations identical before trying to connect them.


More probably it is just an editing error.


Hope to help

Giuseppe



jasonfaraone Tue, 05/19/2009 - 12:49
User Badges:

It's not an editing error; I just haven't had a downtime window to add VLAN 50 to the rest of my switches. It hasn't been a problem with any of my other switches in the loop, so I'm assuming having the same instance name will suffice.

Giuseppe Larosa Tue, 05/19/2009 - 13:26
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jason,

as far as I know it is not enough because the MST BPDU contains a special hash calculated using the vlan to instances mapping.

if the hash values don't match the switches think they are in different MST region.

You have two MST regions already.


see


MST-enabled switches only form an MST region if they have a matching VLAN-to-IST mapping, MST configuration name, and MST revision. If any of these three fails, the port will be flagged as a boundary port.


http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a0080094366.shtml


Hope to help

Giuseppe


Actions

This Discussion