PGW drops calls with NOA=8

Unanswered Question
May 20th, 2009

Hi,

I have a strange problem with my PGW 9.5(2) protocol patch version 70 running in signaling (nailed) mode.

I'm getting a call to a ported number from a partner and the PGW immediately drop the call with release code 28 (address incomplete). When I'm getting not ported number everything is fine. The only difference between the IAM messages is that the one with a ported number has NOA=8 and the normal call has NOA=3

Any ideas what a problem may be?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
ddragoev Wed, 05/20/2009 - 14:31

Hi,

Thank you for your post. Unfortunately I receive the call correctly (length and NOA) according to the local regulatory requirements for the ported numbers.

Paolo Bevilacqua Wed, 05/20/2009 - 15:15

I see. So most likely the PGW is not aware of you local regulatory and uses the international coding.

I think if you contact TAC they should be able to suggest a config or patch for this.

ddragoev Wed, 05/20/2009 - 15:41

Thaks will do. However the numner is 12 digits so I don't think this is the problem

Paolo Bevilacqua Wed, 05/20/2009 - 16:37

Are you getting a routing number prepended to the called number? You should have these configured somewhere in the PGW.

Also, I was wrong about NOA 8 being international, it is not so.

ddragoev Thu, 05/21/2009 - 02:32

I'm getting a routing number prepended but at this point I'm not interest of this as the PGW works in signaling mode and all the routing is happened in the GW. The call is drop before sending the information to the RLM group in the SS7 part

Paolo Bevilacqua Thu, 05/21/2009 - 08:37

Correct, on the other hand the possibilities are two:

1. PGW is not configured correctly for NOA 8.

2. PGW for some reasons interprets the 3+9 digits number as incomplete.

In any case, the TAC should be able to answer easily.

scpage Thu, 05/21/2009 - 14:19

Hi, you need to change your mdo variant on the ss7path from Q761_BASE to Q761_99VER_BASE.

noa=8 was not defined in 1997 version, it was later defined in the 1999 version.

ddragoev Fri, 05/22/2009 - 10:52

I'm in a process of testing now but can confirm with a changing the MDO to Q761_99VER_BASE solved the problem. Thanks everyone

Actions

This Discussion