IPM Importcollector CLI

Unanswered Question
May 21st, 2009
User Badges:

Hi


We are trying to import an existing ip sla collector to IPM 4.1, but when we put the command by CLI, we recieved an error message:


[email protected] # /opt/CSCOpx/bin/ipm importcollector -u admin -p xxxxx -source X.X.X.X -oper all


* Warning * The -p option is highly insecure and *not* recommended.

* Warning * See -u option for more details.


<ipm> ERROR - X.X.X.X is not a valid source device

<ipm> ERROR - Command Execution Failed.

Recommended action:

1. Check whether the given input are valid

2. Check the ipmcli.log for details


SUMMARY

========

Failed: ipm importcollector: Import of Collectors failed.


we watched the ipmcli log, but we didn't understand what it means.







Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Thu, 05/21/2009 - 10:04
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The source device must already be in your DCR, and managed by IPM as a source device. Is this the case?

paulhowlett_2 Fri, 10/07/2011 - 01:00
User Badges:

Hi, resurrecting an old post but I'm getting exactly the same error. The device I'm trying to import is listed under IPM devices in the 'Responder Enabled Devices', I've also tried adding it as an Adhoc target as it is both a collector and responder.

Here is the log for the session I ran:


[ Fri Oct 07  08:52:53 BST 2011 ],INFO ,[main],com.cisco.nm.ipmng.cli.framework.core.IPM,doStuff,351,License check passed...

[ Fri Oct 07  08:52:54 BST 2011 ],INFO ,[main],com.cisco.nm.ipmng.devicemanager.DMDbAccessManager,getDbInstance,53,Initializin DB Interface...

[ Fri Oct 07  08:52:54 BST 2011 ],INFO ,[main],com.cisco.nm.ipmng.devicemanager.DMDbAccessManager,init,64,Getting DB connection...

[ Fri Oct 07  08:52:54 BST 2011 ],INFO ,[main],com.cisco.nm.ipmng.util.db.DBClient,getDbInstance,36,Initializin DB Client...

[ Fri Oct 07  08:52:54 BST 2011 ],INFO ,[main],com.cisco.nm.ipmng.util.db.DBClient,init,46,Getting DB connection...

[ Fri Oct 07  08:52:54 BST 2011 ],INFO ,[main],com.cisco.nm.ipmng.devicemanager.DMDbAccessManager,getDBConnection,73,Getting Connection object from DBClient

[ Fri Oct 07  08:52:54 BST 2011 ],ERROR,[main],com.cisco.nm.

ipmng.devicemanager.DMDbAccessManager,getDCRIdToDisplayName,2079,Error while executing query :null


Can anybody tell me where I'm going wrong please?

Thanks in advance.

Joe Clarke Sat, 10/08/2011 - 16:59
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please start a new thread for your question.  When you do, include your version of LMS.

Actions

This Discussion