UC520 and 2talk (NZ) config question

Unanswered Question
May 21st, 2009

I'm trying to get the UC520 set up with SIP trunking from 2talk (New Zealand).

Does anyone have any experience with setting up 2talk SIP trunks?

According to 2talk they do have customers with UC520's, but they can't give me any config instructions.

I've been playing around with it for a while now (it's a quiet Friday afternoon), but I've come to the conclusion that I need some guidance.

Any help would be much appreciated.

Marc

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Trad Thu, 05/21/2009 - 22:33

Hi There,

Can you post your SIP config up please, and just remember to remove any sensative information from it.

[EDIT]

Oh and i forgot to mention, if you can please add some debugs there might be some information in there to help out as well.

Cheers,

David.

Message was edited by: David Trad

marcmohring Sun, 05/24/2009 - 18:32

Hi David,

SIP config is:

!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco
sip
  registrar server expires max 3600 min 3600
   outbound-proxy ipv4:202.180.76.166:5060
  no update-callerid
!
!
voice source-group CCA_SIP_SOURCE_GROUP
access-list 1
translation-profile incoming SIP_Incoming
!
!
voice translation-rule 411
rule 1 /^1\(.*\)/ /ABCD1\1/
!
voice translation-rule 412
rule 1 /^ABCD\(.*\)/ /\1/
!
!
voice translation-profile SIP_Incoming
translate called 411
!
voice translation-profile SIP_Passthrough
translate called 412
!
!

!
dial-peer voice 1000 voip
permission term
description ** Incoming call from SIP trunk (Generic SIP Trunk Provider) **
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
incoming called-number .%
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1001 voip
corlist outgoing call-local
description ** star code to SIP trunk (Generic SIP Trunk Provider) **
destination-pattern *..
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
!
no dial-peer outbound status-check pots

sip-ua
credentials username 028255xxxxx password 7 105611011D0F0A1314 realm 202.180.76
.166
no remote-party-id
retry invite 2
retry register 10
timers connect 100
sip-server ipv4:202.180.76.166:5060
  host-registrar
!
!
ephone-dn  123
number 95791095
description SIP Main Number registration
preference 10

This is the first time I've tried to set up a SIP trunk, so if I've missed anything, let me know.

I've also attached a file with some dbug info.

Thanks,

Marc

Attachment: 
a.cirilovic Wed, 05/27/2009 - 14:51

Hi

I think you are using the  wrong ip address- you are supposed to set up sip link with the host trunk.2talk.co.nz which is 202.180.76.164 not 166. Give it a go and see what happens, my config worked (almost) straight away. Don't forget to enable sip trunk forwarding on the 2talk setup page (i am assuming you  have public IP for the UC520). If it gives you more grief, I'd doublecheck firewall ACLs

Regards, Aleks

Actions

This Discussion