Cisco Click to call prefix

Unanswered Question
May 22nd, 2009

Hey guys,

I will lose my mind with this web-application. In my environment I have setup to use 0 as prefix before digits so the call will go out.

The question is where to setup this in the Click to call app. When I will find a digit on the web site or in the Outlook it will automatic add 0 prefix before digit.

Is it possible to change + to "" or to 00 despide on the area code?

For example this is just the idea ->


Thank you all for your help and answer.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Dennis Mink Mon, 05/25/2009 - 22:57

In conjunction with what?

call manger?

in schich case have a look at call routing-->dial rules-->application dial rules

sebastjan.stucl Tue, 05/26/2009 - 01:36

Hello minkdennis!

Yes regarding on Call manager. I have problem with application and *.pdf because those keys that should be in windows regex does not exist (some "+" dialing rules).

Ok you said that you setp app. rules but when will they work? How do I apply this rules? Will they start to work automatic when I will change he app dialing ruls?

The call itself is working but I have to change those things like adding prefix.

Thank you minkdennis for your response!

Dennis Mink Tue, 05/26/2009 - 20:31

I am using the application dial rules with CUPC, and the are active straight away.

one click dial uses TSP and some sort of CTI control on your desk phone.

it is easy enough to test out if it works.

you apply a rule, say 123123 that translates into your mobile number, and use click to dial, to dial 123123, see what happens.

Let me know

Dennis Mink Tue, 05/26/2009 - 20:34

here is an example of what I have set up

Description Number Begins With Number of Digits Total Digits to be Removed Prefix With Pattern

Mobile numbers 04 10 0 0

VIC 10 digits +61 12 3 00

nikger1980 Wed, 03/13/2013 - 02:26

Some years before but i write it here, it might help someone.

The dial rules that was written are right, but before you must go to Service parameters, Web dialer service and make "true" the "Apply Application dial Rules on Dial" and the "Apply Application Rules on SOAP Dial Request".

Then, restart the WebDialer service from the Serviceability menu.

Then, the above rules should work (application dial rules).



This Discussion