×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

NAT not working on Cisco Router

Answered Question
May 22nd, 2009
User Badges:

I configured NAT on a cisco 2811 router running but it's not working. Following are the commands:


interface FastEthernet0/0

ip address 192.168.1.7 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 172.16.20.106 255.255.255.252

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.20.105

ip route 10.2.8.0 255.255.248.0 172.16.20.105

!

ip http server

no ip http secure-server

ip nat source static 192.168.1.112 10.234.8.2

!

I try to ping 10.2.8.15 from a Laptop (192.168.1.112) connected to the NAT inside interface but ping is unsuccesful and when i do a show ip nat translation i see nothing. I've erased the nvram and reconfigured same nat commands without success. I've also tried dynamic nat using "ip nat source list pool" command without success. I'm surprised. The ios image is (C2800NM-ADVSECURITYK9-M), Version 12.4(3i). Please assist. Thanks.

Correct Answer by paolo bevilacqua about 8 years 2 months ago

Configure:


no ip nat source static 192.168.1.112 10.234.8.2

ip nat inside source static 192.168.1.112 10.234.8.2


or pool dynamic, or interface.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
paolo bevilacqua Fri, 05/22/2009 - 10:17
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Configure:


no ip nat source static 192.168.1.112 10.234.8.2

ip nat inside source static 192.168.1.112 10.234.8.2


or pool dynamic, or interface.

imuonagor Fri, 05/22/2009 - 11:40
User Badges:

Thanks so much. Spent hours wondering why where it's just due to my skipping the inside keyword. But then, I wonder, how come the router took the command?

Thanks anyway.

imuonagor Fri, 05/22/2009 - 11:40
User Badges:

Thanks so much. Spent hours wondering why whereas it's just due to my skipping the inside keyword. But then, I wonder, how come the router took the command?

Thanks anyway.

paolo bevilacqua Fri, 05/22/2009 - 12:09
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Because it does something else, that is not of much use anyway.


Thanks for the nice rating and good luck!


imuonagor Sat, 05/23/2009 - 08:27
User Badges:

If you don't mind explaining, I'd like to know the something else that it does. I ran debugs then but didn't see anything.

Actions

This Discussion