3750 does not 'save' config;is this related to password-recovery?

Unanswered Question
May 22nd, 2009

Folks, I configure the switch below, do 'write mem'. Then I do show run and my configuration is not saved.

Is this related to the status 'password-recovery' feature enabled as shown below?

If so, I have been trying to find the documentation on how to change the registry to avoid this issue and get out of the password recovery feature. Is this done thru registry config or this is a button on the switch? Switch is on remote site.

ROM: Bootstrap program is C3750 boot loader

BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.2(25r)SEC, RELEASE SOFTWAR

E (fc4)

sw1 uptime is 11 weeks, 1 hour, 55 minutes

System returned to ROM by power-on

System image file is "flash:c3750-ipservices-mz.122-25.SEE3/c3750-ipservices-mz.


cisco WS-C3750-24TS (PowerPC405) processor (revision N0) with 118784K/12280K byt

es of memory.

Processor board ID OMITTED

Last reset from power-on

1 Virtual Ethernet interface

24 FastEthernet interfaces

2 Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jon Marshall Fri, 05/22/2009 - 13:49


The password-recovery mechanism should not stop the config being saved. If enabled it allows someone with physical access to the switch to hold down the mode button while reloading the switch and then to reset the password.

What is it you are trying to save.


news2010a Fri, 05/22/2009 - 13:51

True. I just did 'no service password-recovery' and behavior is the same.

I am trying to configure the switch. Regular configuration such as:

config t

int fa1/0/1

switchport mode access

siwtchport access vlan 3

no shut


then I do write mem.

I do show run and my configuration is not displayed. No ports appear on show run.

I have never seen this before...

iyde Sat, 05/23/2009 - 01:12

Is it just me misunderstanding your posting? To see a saved config you use 'show start', not 'show run'

Or do you do a reload and then the config is missing?


This Discussion