AIR-AP1231G-A-K9, Multiple BVI interfaces?

Unanswered Question
May 22nd, 2009

Is it possible to create multiple BVI interfaces and assign each of them IP addresses of different VLANs?

I have this AP and it's broadcasting 2 SSIDs (1 on VLAN1 and another on VLAN17). They work fine. The BVI 1 has IP 10.0.1.100/24 and BVI 17 has 172.17.252.100/16. The switch is 3750 and vlan1 interface has IP 10.0.1.10/24 and vlan17 interface has IP 172.17.254.10/16. However only BVI is pingable but not BVI 17. Can I use BVI 17 interface and its IP for management? Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
weterry Fri, 05/22/2009 - 20:06

If you have vlan 1 and 17 working, then I assume you have subinterfaces for both the radio and the fast ethernet port? And each sub-interface is correctly mapped to a bridge-group of the BVI?

Maybe need to add "bridge 17 route ip"?

Post your config please?

Difan Zhao Mon, 05/25/2009 - 07:55

Here is the config. I can't put "bridge 17 route ip" on. It says that route ip is only allowed on bridge group 1. Thanks!

Building configuration...

Current configuration : 2090 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret 5 $1$.CHB$zRbJ5fqZ7HG817zSv1P0k.

!

ip subnet-zero

!

!

no aaa new-model

dot11 vlan-name GN vlan 17

dot11 vlan-name Native vlan 1

!

dot11 ssid SSID_VLAN1

vlan 1

authentication open

mbssid guest-mode

!

dot11 ssid SSID_VLAN17

vlan 17

authentication open

mbssid guest-mode

!

!

!

username Cisco password 7 05280F1C2243

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid SSID_VLAN1

!

ssid SSID_VLAN17

!

mbssid

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.17

encapsulation dot1Q 17

no ip route-cache

bridge-group 17

bridge-group 17 subscriber-loop-control

bridge-group 17 block-unknown-source

no bridge-group 17 source-learning

no bridge-group 17 unicast-flooding

bridge-group 17 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

hold-queue 160 in

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.17

encapsulation dot1Q 17

no ip route-cache

bridge-group 17

no bridge-group 17 source-learning

bridge-group 17 spanning-disabled

!

interface BVI1

ip address 10.0.1.100 255.255.255.0

no ip route-cache

!

interface BVI17

ip address 172.17.252.100 255.255.0.0

no ip route-cache

!

ip default-gateway 10.0.1.254

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode