LMS 3.1 Ciscoview issues

Answered Question
May 22nd, 2009
User Badges:

I am getting the following message when trying to use ciscoview to pull a gui view of a device


Error

Message

Cannot find applicable device package for 205.127.192.1.

This error could be due to one of the following:

- The device package for this device type is not installed.

- Device support for this device type is not available.

- You are trying to open a component inside a device.

To correct the problem, either install a device package for the device type, or open the parent device to manage the component.

Now, I do have the correct packages installed. When I was running lms 3.0 on the same server, it worked fine.


4500's and 6500's appear to have the issue.

Correct Answer by Joe Clarke about 8 years 4 days ago

Use the command:


net stop crmdmgtd


Then copy the files. Then run the following command to restart Daemon Manager:


net start crmdmgtd

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Fri, 05/22/2009 - 15:12
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What are the sysObject IDs of the devices which are giving this error?

jlhainy Fri, 05/22/2009 - 15:21
User Badges:

116. 1.3.6.1.4.1.9.1.502 Cisco Catalyst 4506 Switch Cat4000IOS 16.0

117. 1.3.6.1.4.1.9.1.875 Cisco Catalyst 4506-E Switch Cat4000IOS 16.0

118. 1.3.6.1.4.1.9.1.501 Cisco Catalyst 4507R Switch Cat4000IOS 16.0

119. 1.3.6.1.4.1.9.1.876 Cisco Catalyst 4507R-E Switch Cat4000IOS 16.0

120. 1.3.6.1.4.1.9.1.537 Cisco Catalyst 4510R Switch Cat4000IOS 16.0

121. 1.3.6.1.4.1.9.1.877 Cisco Catalyst 4510R-E Switch Cat4000IOS 16.0

138. 1.3.6.1.4.1.9.5.44 Cisco Catalyst 6509 Switch Cat6000 9.1

139. 1.3.6.1.4.1.9.5.50 Cisco Catalyst 6513 Switch Cat6000 9.1



Joe Clarke Fri, 05/22/2009 - 19:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

These are the sysObjectIDs supported by these packages, but are they actually yhe sysObjectIDs of your problem devices? Also, post the list of contents in the NMSROOT/www/classpath/com/cisco/nm/xms/psu/pkgs/cvw and NMSROOT/MDC/tomcat/webapps/CVng/WEB-INF/classes/com/cisco/nm/cvw/devpkgs directories.

jlhainy Tue, 05/26/2009 - 05:06
User Badges:

after compairing the two directories, I noticed that the www dir has cat400IOS.zip but the mdc dir does not.


The sysObjectID's are correct. Again, ciscoview was working fine until I upgraded to lms 3.1 Other devices are still working fine.

Joe Clarke Tue, 05/26/2009 - 08:56
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the list of contents from the two directories.

Joe Clarke Tue, 05/26/2009 - 10:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You have six packages out of sync between the two directories. Copy all of the .zip files from the www directory to the MDC directory. Then restart Daemon Manager, and you should be able to open these switches in CiscoView.

Correct Answer
Joe Clarke Tue, 05/26/2009 - 11:15
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Use the command:


net stop crmdmgtd


Then copy the files. Then run the following command to restart Daemon Manager:


net start crmdmgtd

jlhainy Tue, 05/26/2009 - 11:35
User Badges:

Great! That worked out. thank you very much. One last question. When I bring up the ciscoview interface, it states that the DCR server is down and needs to be restarted. How can I troubleshoot and resolve this?

Joe Clarke Tue, 05/26/2009 - 11:54
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This is probably a timing issue. If the error still occurs after 30 minutes, start a new thread.

jlhainy Tue, 05/26/2009 - 12:25
User Badges:

Tried it again & it seems to be working now. Thanks again for the help!

Actions

This Discussion