covad PPPoFR. no default GW. why?

Answered Question
May 23rd, 2009

according to the docs this config below should work but i don't seem to have a default route installed. whats worse is that i cannot add a static route to the virtual-access interface that gets built after the passwords are accepted.

Leon

-----------------------

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 21.13.12.177 255.255.255.248

!

interface Serial0/0:1

no ip address

encapsulation frame-relay IETF

!

interface Serial0/0:1.1 point-to-point

frame-relay interface-dlci 16 ppp Virtual-Template1

!

interface Virtual-Template1

ip address negotiated

ppp chap hostname xxxx

ppp chap password 0 yyyy

ppp ipcp dns request

ppp ipcp route default

ppp ipcp address accept

I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 7 years 8 months ago

I'm referring to:

ip local pool default 10.10.10.10 10.10.10.11

About which you have not reported.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ldmccalla Sat, 05/23/2009 - 11:40

i wish it was that easy. I think covad is not returning a default GW when cisco makes a PPP request for it.

Gateway of last resort is not set

21.13.12.0/29 is subnetted, 1 subnets

C 21.13.12.176 is directly connected, FastEthernet0/0.3

20.86.15.0/32 is subnetted, 1 subnets

C 20.86.15.119 is directly connected, Virtual-Access1

Paolo Bevilacqua Sat, 05/23/2009 - 11:51

Covad does not need to return anything, the default route is installed once IPCP is open (interface up).

If it doesn't work, may be a bug, just configure default pointing to virtual-template.

ldmccalla Sat, 05/23/2009 - 21:00

Windsor1760(config)#ip route 0.0.0.0 0.0.0.0 virtual-?

Virtual-PPP Virtual-TokenRing

Virtual-Template is not an option for the ip-route statement. the defaut-route is not automatically installed and i cannot manually point it to the Virtual Access interface that is added.

Leon

ldmccalla Sat, 05/23/2009 - 23:16

virtual-ppp can't be added since it doesn't exist and adding the serial sub-int is pointless because the sub-int has "no ip address" and ultimately that route doesn't make it to the route table.

Paolo Bevilacqua Sun, 05/24/2009 - 10:18

A serial interface doesn't need to have an predetermined IP address to be used in a static route. Or, you can use 20.86.15.119 instead that is the address of remote router.

ldmccalla Sun, 05/24/2009 - 11:00

the IP assigned on the virtual interface is my WAN ip. i don't believe it is the remote IP.

from what i understand, the PPP interface is like a tunnel and i need to send the data down that tunnel. right now the serial interface has no ip and accordingly i cannot add a static route to something that is not IP enabled.

when i add an IP address such as 1.1.1.1 to the serial interface then make the serial interface the default route, packets go out the interface but never make it to the internet.

I need to route down the "Virtual-Access 1" interface but i can't. what am i missing?

Leon

Attachment: 
Paolo Bevilacqua Sun, 05/24/2009 - 11:40

Have you edited the output, right ?

Can you take "debug ppp neg" with "term mon" ? Another /32 route for the peer, should be installed for you to use as default. You can try to use 209.86.152.119 anyway.

ldmccalla Sun, 05/24/2009 - 11:54

i tried to delete the 3rd digit from the IPs to change keep things private but its not working anyway...

here is the debug.

i think the default route is not being added to the PPP profile by my provider. unfortunately Earthlink wants me to use the netopia they sent instead of my 1760 so i can't really complain to them.

on the other hand, i should be able to add a default route to point to the PPP interface but i don't know how to do so.

Leon

Attachment: 
Paolo Bevilacqua Sun, 05/24/2009 - 12:07

Go ahead and use 209.86.152.119 let us know if it works.

Remote doesn't come with an own address and seems even willing to accept one. That is the reason why ppp ipcp default route didn't work in first place.

There is no such thing as passing a default route in PPP, it's purely a local decision.

ldmccalla Sun, 05/24/2009 - 14:11

Windsor1760(config)#ip route 0.0.0.0 0.0.0.0 209.86.152.119

%Invalid next hop address (it's this router)

Windsor1760(config)#

i'm sure a default gateway is to be assigned the same way the WAN address is assigned. with dial-up PPP you get your IP as well as the default gateway. why shouldn't this be any different.

"ppp ipcp route default" this command should ask for the GW ip i'm sure.

Leon

Paolo Bevilacqua Sun, 05/24/2009 - 15:04

Dialup PPP is different from router logic, the thing here is that the remote does not communicate an address. Can be an oversight by covad.

The command ppp ipcp route default does not ask for anything, compare traces with and without if you don't believe.

Try this:

interface virtual-template 1

peer default ip address 10.10.10.10

That may lead the ppp ipcp route default to start working once the remote IP address is known.

ldmccalla Sun, 05/24/2009 - 18:01

Windsor1760(config)#int virtual-Tem 1

Windsor1760(config-if)#peer default ip address ?

dhcp Use DHCP proxy client mechanism to allocate a peer IP address

dhcp-pool Use local DHCP pools to allocate a peer IP address

pool Use IP pool mechanism to allocate a peer IP address

Windsor1760(config-if)#peer default ip address 10.10.10.10

^

% Invalid input detected at '^' marker.

Windsor1760(config-if)#

Paolo Bevilacqua Sun, 05/24/2009 - 18:24

Right, an explicit address is not allowed on an virtual interface, to prevent multiple assigments.

Go ahead and configure a pool

ip local pool default 10.10.10.10 10.10.10.11

and use pool in peer default ip address

All this in the hope of finally providing the remote with a valid address.

ldmccalla Sun, 05/24/2009 - 20:42

the command is entered but it won't stick in the running config.

Windsor1760(config-if)#peer default ip address pool

Windsor1760#sh run | s Tem

frame-relay interface-dlci 16 ppp Virtual-Template1

interface Virtual-Template1

ip address negotiated

ppp chap hostname ms23808095

ppp chap password 0 uzasgu8f

ppp pap sent-username ms23808095 password 0 uzasgu8f

ppp ipcp dns request

ppp ipcp route default

ppp ipcp address accept

Windsor1760#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Windsor1760(config)#int virtual-Tem 1

Windsor1760(config-if)#no ppp ipcp route default

Windsor1760(config-if)#peer default ip address pool

Windsor1760(config-if)#do sh run | s Tem

frame-relay interface-dlci 16 ppp Virtual-Template1

interface Virtual-Template1

ip address negotiated

ppp chap hostname ms23808095

ppp chap password 0 uzasgu8f

ppp pap sent-username ms23808095 password 0 uzasgu8f

ppp ipcp dns request

ppp ipcp address accept

Paolo Bevilacqua Mon, 05/25/2009 - 08:12

Have you configured the pool ?

Can you take the ppp trace again ?

It may not stick due to using the default pool.

For sure you're meeting a lot of undue difficulties.

Paolo Bevilacqua Sun, 05/24/2009 - 15:28

Also very strange is how the router keeps sending CONFreq before finally accepting the reply more than one minute later.

But, let's see if you resolve the connectivity problem first.

rakesh.hegde Mon, 05/25/2009 - 10:40

Hi,

Your configuration looks good. Can you please try the following configuration ?

interface Virtual-Template1

no ip address

ppp multilink

ppp multilink group 1

ppp chap hostname xxxx

ppp chap password 0 yyyy

interface Multilink1

ip address negotiated

ppp ipcp route default

ppp ipcp dns request

ppp multilink

ppp multilink group 1

If you still dont see the default route, add a static default ponting to Multilink1 interface

HTH,

Rakesh

ldmccalla Mon, 05/25/2009 - 11:59

not that i haven't tried this already but this was indeed a valiant attempt. the problem is that Multilink1 does NOT get assigned an IP. "Virtual-Access 1" is created with the IP and so that's where i need to route my data to. when i point the default GW to multilink 1 the result is the same as when i pointed the default GW to Serial 0/0:1.1. In that situation, the static route never made it to the route table because the interface does NOT have an IP.

i need to be able to set the default gw to "Virtual-Access 1"

PS i also tried using a route-map to force all traffic to "virtual-Template 1" and that didn't help

Leon

Covad1760(config)#ip route 0.0.0.0 0.0.0.0 multilink 1

Covad1760(config)#

Covad1760#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

65.0.0.0/28 is subnetted, 1 subnets

S 65.15.36.64 [1/0] via 172.16.0.1

172.16.0.0/24 is subnetted, 1 subnets

C 172.16.0.0 is directly connected, FastEthernet0/0.1

216.135.129.0/29 is subnetted, 1 subnets

C 216.135.129.176 is directly connected, FastEthernet0/0.3

209.86.152.0/32 is subnetted, 1 subnets

C 209.86.152.119 is directly connected, Virtual-Access1

Covad1760#sh ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES NVRAM up up

FastEthernet0/0.1 172.16.0.5 YES manual up up

FastEthernet0/0.2 unassigned YES NVRAM deleted down

FastEthernet0/0.3 216.135.129.177 YES manual up up

Serial0/0:1 unassigned YES manual up up

Serial0/0:1.1 unassigned YES unset up up

NVI0 unassigned NO unset up up

Multilink1 unassigned YES manual down down

Virtual-Access1 209.86.152.119 YES IPCP up up

Virtual-Template1 unassigned YES manual down down

Virtual-Access2 unassigned YES unset down down

Covad1760#

interface Multilink1

ip address negotiated

ppp ipcp dns request

ppp ipcp route default

ppp multilink

ppp multilink group 1

!

interface Serial0/0:1

no ip address

encapsulation frame-relay IETF

!

interface Serial0/0:1.1 point-to-point

frame-relay interface-dlci 16 ppp Virtual-Template1

!

interface Virtual-Template1

ip address negotiated

ppp chap hostname ms23808095

ppp chap password 0 uzasgu8f

ppp pap sent-username ms23808095 password 0 uzasgu8f

ppp multilink

ppp multilink group 1

rakesh.hegde Mon, 05/25/2009 - 12:48

Hi,

Please remove "ip address negotiated" from interface Virtual-Template1.

-Rakesh

ldmccalla Mon, 05/25/2009 - 13:15

Covad1760#sh ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES NVRAM up up

FastEthernet0/0.1 172.16.0.5 YES manual up up

FastEthernet0/0.2 unassigned YES NVRAM deleted down

FastEthernet0/0.3 216.135.129.177 YES manual up up

Serial0/0:1 unassigned YES manual up up

Serial0/0:1.1 unassigned YES unset up up

NVI0 unassigned NO unset up up

Multilink1 unassigned YES manual down down

Virtual-Access1 unassigned YES TFTP up up

Virtual-Template1 unassigned YES manual down down

Virtual-Access2 unassigned YES unset down down

Covad1760#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

65.0.0.0/28 is subnetted, 1 subnets

S 65.15.36.64 [1/0] via 172.16.0.1

172.16.0.0/24 is subnetted, 1 subnets

C 172.16.0.0 is directly connected, FastEthernet0/0.1

216.135.129.0/29 is subnetted, 1 subnets

C 216.135.129.176 is directly connected, FastEthernet0/0.3

Covad1760#

rakesh.hegde Mon, 05/25/2009 - 13:23

Have you bounced your serial interface to re-initiate PPP negotiation ? If so, its time to call the TAC I guess.

-Rakesh

ldmccalla Mon, 05/25/2009 - 13:36

yes i bounce the controller.

the whole reason i'm here is bacause my 1760 is EOL and so TAC won't renew the service contract.

Cisco refuses to take my money.

Leon

rakesh.hegde Mon, 05/25/2009 - 14:08

Can you please trun on "debug ppp negotiation" ? Do a shut/no shut on ser 0/0 and post the output . Also,please post sh ip int brief.

-Rakesh

ldmccalla Mon, 05/25/2009 - 14:15

there is a debug with my original config attached to my post at "May 24, 2009, 12:54pm PST". here is the debug with multilink and without ip negotiation.

Leon

Attachment: 
Paolo Bevilacqua Mon, 05/25/2009 - 21:22

Have you tried with pool configured ?

May 24 15:52:00.070: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10

May 24 15:52:00.074: Vi1 IPCP: Address 0.0.0.0 (0x030600000000)

May 24 15:52:00.074: Vi1 IPCP: Cannot satisfy pool request

May 24 15:52:00.074: Vi1 IPCP: Neither side knows remote address

ldmccalla Tue, 05/26/2009 - 03:40

see my "May 24, 2009, 7:01pm PST" post. the command is entered but it does not stay in the config when i do show run it is not there.

how can i get TAC to help? they won't take my money because my 1760 is EOL but this is clearly an IOS issue. I'm sure a brand new 1801 would fail. if i plug the Covad Netopia in, it works just fine.

Correct Answer
Paolo Bevilacqua Tue, 05/26/2009 - 07:11

I'm referring to:

ip local pool default 10.10.10.10 10.10.10.11

About which you have not reported.

ldmccalla Tue, 05/26/2009 - 07:53

5/24/2009, 7:24pm PST you said..

Go ahead and configure a pool

ip local pool default 10.10.10.10 10.10.10.11

and use pool in peer default ip address

then in my reply i told you that the "peer default ip address" command did not show up in the virtual Template after i entered it repeatedly.

anyway based on your advice i used:-

interface Virtual-Template1

peer default ip address pool LOCAL

ip local pool LOCAL 10.10.10.10 10.10.10.11

and it worked..thanks a lot.

Attachment: 
ldmccalla Tue, 05/26/2009 - 03:49

sorry... the information was in the "May 24, 2009, 9:42pm PST" post

Leon

rakesh.hegde Tue, 05/26/2009 - 11:42

Hi,

The real issue is why your router is not installing a host route to the IP address of the PPP server. The default route will be installed only if you see this host route first. The default route will be pointing to the PPP server IP learned during IPCP negotiation, not to the assigned IP address.

Gateway of last resort is 1.1.1.1 to network 0.0.0.0

1.0.0.0/32 is subnetted, 1 subnets

C 1.1.1.1 is directly connected, Virtual-Access2

192.168.1.0/32 is subnetted, 1 subnets

C 192.168.1.8 is directly connected, Virtual-Access2

S* 0.0.0.0/0 [1/0] via 1.1.1.1

I took a look at your original debugs and it looks like the Covad router is asking your router for an IP address. This can happen if Covad router's virtual template is configured with " ip address negotiated" as well . I guess they want you to use Netopia box because it installs a default gateway pointing to the assigned IP address.

-Rakesh

Paolo Bevilacqua Tue, 05/26/2009 - 11:45

This issue is now resolved.

Remote needed to be assigned an address via ip pool, as indicated in previous posts of mine.

This allows both an host and default route to be installed.

Actions

This Discussion