3951 on cme place call very slowly

Answered Question
May 23rd, 2009
User Badges:

we has create a environment base on CME 7.0 and 3951, 7940 phones. 3951 registe to cme success. but when 3951 place call to another phone, was very slowly. but 7940 place call to 3951 was faster. who know what problem happen?


very thanks

Correct Answer by Nicholas Matthews about 8 years 1 month ago

The reason they are different is because they are running completely different protocols. Your 7940/70 is running SCCP and your 3951 is running SIP.


Based on the way SIP works your phone is not going to get the complete dial plan on every digit because SIP sends digits enbloc rather than digit by digit.


You can load the dial plan to the phone like this:


voice register dialplan 1

pattern 1..

pattern 2..


voice register pool 1

dialplan 1


voice register global

create profile


voice register pool 1

reset




-nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
nesharm2 Sun, 05/24/2009 - 22:34
User Badges:
  • Bronze, 100 points or more

Is it happening with internal call or for the PSTN calls ?

Can you attach the show run from the router ?


~Neeraj

wildlynxcisco Sun, 05/24/2009 - 23:42
User Badges:

was internal call very slow, PSTN Call not test yet.


follow is sh run:



Test-VG3845#sh run

Building configuration...


Current configuration : 4771 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Test-VG3845

!

boot-start-marker

boot-end-marker

!

! card type command needed for slot/vwic-slot 0/3

logging message-counter syslog

logging buffered 512000

enable secret 5 $1$RdRQ$/z0qcYWroETxtJLlhIXNJ0

!

no aaa new-model

clock timezone BeiJing 8

!

ip source-route

ip cef

!

!

ip dhcp excluded-address 10.62.54.1 10.62.54.15

!

ip dhcp pool Voice

origin file flash:/static-bindings.txt

default-router 10.62.54.1

option 150 ip 10.62.54.1

dns-server 10.62.54.1

!

!

no ip domain lookup

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

voice-card 0

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

sip

registrar server expires max 600 min 60

!

!

!

!

!

!

!

!

!

!

!

!

!

!

voice register global

mode cme

source-address 10.62.54.1 port 2000

max-dn 720

max-pool 262

load 3951 SIP3951.8-1-1b

timezone 42

time-format 24

create profile sync 0004418369708934

ntp-server 10.62.54.1 mode directedbroadcast

!

voice register dn 201

number 201

name WJ-201

!

voice register dn 202

number 202

name WJ-202

!

voice register dn 203

number 203

name WJ-203

!

voice register dn 204

number 204

name WJ-204

!

voice register dn 205

number 205

name WJ-205

!

voice register dn 206

number 206

name WJ-206

!

voice register pool 201

id mac 000A.8AFF.F76C

type 3951

number 1 dn 201

username 201 password cisco

!

voice register pool 202

id mac 000A.8AFF.F7E1

type 3951

number 1 dn 202

username 202 password cisco

!

voice register pool 203

id mac 000A.8AFF.F4AE

type 3951

number 1 dn 203

username 203 password cisco

!

voice register pool 204

id mac 000A.8AFF.FA01

type 3951

number 1 dn 204

username 204 password cisco

!

voice register pool 205

id mac 000A.8AFF.F58F

type 3951

number 1 dn 205

username 205 password cisco

!

voice register pool 206

id mac 000A.8AFF.FA77

type 3951

number 1 dn 206

!

!

!

!

!

archive

log config

hidekeys

!

!

wildlynxcisco Sun, 05/24/2009 - 23:43
User Badges:

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 10.128.135.77 255.255.255.0

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1.12

encapsulation dot1Q 12 native

ip address 10.62.53.1 255.255.255.0

!

interface GigabitEthernet0/1.112

encapsulation dot1Q 112

ip address 10.62.54.1 255.255.255.0

!

interface Integrated-Service-Engine4/0

no ip address

shutdown

!Application: CUE Running on NME

no keepalive

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.128.135.1

!

!

ip http server

ip http path flash:gui

!

!

!

!

tftp-server flash:P00308000500.bin

tftp-server flash:P00308000500.loads

tftp-server flash:P00308000500.sb2

tftp-server flash:P00308000500.sbn

tftp-server flash:BOOT3951.0-0-0-9.zz

tftp-server flash:DSP3951.0-0-0-2.zz

tftp-server flash:SIP3951.8-1-1-4.zz

tftp-server flash:SIP3951.8-1-1b.loads

tftp-server flash:ATA030203SCCP051201A.zup

tftp-server flash:static-bindings.txt

tftp-server flash:apps70.8-4-1-23.sbn

tftp-server flash:cnu70.8-4-1-23.sbn

tftp-server flash:cvm70sccp.8-4-1-23.sbn

tftp-server flash:dsp70.8-4-1-23.sbn

tftp-server flash:jar70sccp.8-4-1-23.sbn

tftp-server flash:SCCP70.8-4-2S.loads

tftp-server flash:term70.default.loads

tftp-server flash:S00105000300.sbn

!

control-plane

!

!

!

ccm-manager fax protocol cisco

!

mgcp fax t38 ecm

!

!

!

!

!

telephony-service

em logout 0:0 0:0 0:0

max-ephones 262

max-dn 720

ip source-address 10.62.54.1 port 2000

ip qos dscp af11 media

ip qos dscp cs2 signal

ip qos dscp af43 video

ip qos dscp 25 service

load 7914 S00105000300

load 7960-7940 P00308000500

load 7970 SCCP70.8-4-2S

load ata ATA030203SCCP051201A

time-zone 42

time-format 24

max-conferences 12 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn 1 octo-line

number 100

name WenJun 100

!

!

ephone-dn 110 dual-line

number 110

name WenJun 110

!

!

ephone-dn 151 dual-line

number 151

name WenJun 151

!

!

ephone 100

mac-address 0024.C4BE.27DE

speed-dial 10 110 label "110"

type 7970 addon 1 7914

button 1:1 10:151 12:110

!

!

!

ephone 110

mac-address 0024.C4FE.7F7A

type 7940

button 1:110

!

!

!

ephone 151

mac-address 0024.97A9.2CBF

max-calls-per-button 2

type ata

button 1:151

!

!

!

line con 0

line aux 0

line 258

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120

line vty 0 4

password cisco

login

!

scheduler allocate 20000 1000

ntp server 10.62.54.1 prefer

end


Test-VG3845#

nesharm2 Mon, 05/25/2009 - 01:43
User Badges:
  • Bronze, 100 points or more

Can you recheck if its the phone dialing slowly or the numbers.


I mean if you dial a number starting with 1xx is it slow or 2xx


Try interchanging a numbers with phone and let me know the exact details.


for example


101(7940 phone ) dial 201 (3911 phone ) slow etc

wildlynxcisco Mon, 05/25/2009 - 19:49
User Badges:

110(7940)->100(7970) fast

100(7970)->201(3951) fast


202(3951)->201(3951) slow

202(3951)->100(7970) slow

nesharm2 Mon, 05/25/2009 - 22:13
User Badges:
  • Bronze, 100 points or more

Thanks for the reply


However can we have a scenario like


202(7940) to 201(7940) ?

wildlynxcisco Mon, 05/25/2009 - 23:40
User Badges:

202 & 201 was 3951


3951 ip phone -> 3951 ip phone slow


7940 ip phone -> 7940 ip phone fast

nesharm2 Tue, 05/26/2009 - 03:30
User Badges:
  • Bronze, 100 points or more

right ..is it possible to change the dn's

I mean swap the dn(number/extension) for 7940 and 3911


Can u put 202 on a 7940 phone and check ..

Correct Answer
Nicholas Matthews Tue, 05/26/2009 - 16:18
User Badges:
  • Red, 2250 points or more

The reason they are different is because they are running completely different protocols. Your 7940/70 is running SCCP and your 3951 is running SIP.


Based on the way SIP works your phone is not going to get the complete dial plan on every digit because SIP sends digits enbloc rather than digit by digit.


You can load the dial plan to the phone like this:


voice register dialplan 1

pattern 1..

pattern 2..


voice register pool 1

dialplan 1


voice register global

create profile


voice register pool 1

reset




-nick

wildlynxcisco Tue, 05/26/2009 - 22:10
User Badges:

very thanks your help.


we add dialplan to register pool follow your steps, the delay still about 5 seconds. that's normal? and in voice regoster dialplan, we must indicate type "7905-7912" or "7940-7960-others", so i set to "7905-7912", that's right?


and i think the problem did related to "interdigital timeout" ?




Nicholas Matthews Wed, 05/27/2009 - 04:36
User Badges:
  • Red, 2250 points or more

I haven't made a dial plan for the 3951 before, but I would just test them all until one works. Make sure that you go back to voice register global and 'create profile' to update the files that get downloaded to the phone each time.


But yes, the problem is the interdigit timeout.


-nick

chenhao Wed, 06/17/2009 - 23:48
User Badges:

very thanks your help. we had resolved the problem. and we find the timeout interdigital command and voice register dialplan was mutex, that's normal?

paolo bevilacqua Thu, 06/18/2009 - 00:01
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

"was mutex" ???

Which language is that ?

Actions

This Discussion