Internet connectivity problem with cisco router

Answered Question
May 24th, 2009
User Badges:

Dear buddy,

I have a Internet connection with ADSL modem of a subscriber of 2MB and i have a cisco 2821 router.

i want to connect Internet through this router.Kindly help me to configure router for Internet connectivity.Internet line is connected from ADSL modem to router's fastethernet0/0.In router's fastethernet0/1 is connected with our LAN.

I want to connect our LAN to Internet.


IP add at fastethernet0/0(IP add my side for Internet)-122.160.156.x

Ip add (service provider end)-122.160.156.x+1

DNS IP-202.125.145.y

Alternet DNS IP-202.125.145.y+1

IP add at fastethernet0/1(Local LAN)-192.168.1.z


Correct Answer by cisco24x7 about 8 years 6 days ago

ip dhcp pool mynet

network 192.168.1.0

default-router 192.168.1.x

dns-server 202.125.145.y 202.125.145.y+1

update arp


access-list 100 permit ip 192.168.1.0 0.0.0.255 any


ip nat inside source list 100 interface F0/0 overload


interface F0/0

ip nat outside


interface F0/1

ip nat inside


Easy right?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
cisco24x7 Sun, 05/24/2009 - 15:31
User Badges:
  • Silver, 250 points or more

ip dhcp pool mynet

network 192.168.1.0

default-router 192.168.1.x

dns-server 202.125.145.y 202.125.145.y+1

update arp


access-list 100 permit ip 192.168.1.0 0.0.0.255 any


ip nat inside source list 100 interface F0/0 overload


interface F0/0

ip nat outside


interface F0/1

ip nat inside


Easy right?

Actions

This Discussion