Need command guidance on setting up inter vlan routing between 3550/1841

Answered Question
May 25th, 2009

This is my goal

1. Internet Cloud

2. Cisco 1841 Router: 10.10.10.1 (This router only has two ports, FA0/1 to internet and FA0/0 to the 3550 switch)

3. Cisco 3550: 10.10.10.2 on VLAN1 (Management VLAN)

4. Clients VLAN20: 10.10.20.1 255.255.255.0

5. Servers VLAN30: 10.10.30.1 255.255.255.0

6. One DHCP\DNS Server on VLAN 30

I would like to enable Layer 3 routing on the 3550 and avoid the sub interfaces on the router if it is not needed and I need to be able to have the clients request an IP from the DHCP server on VLAN 30.

What are the commands I need to get this network setup working.

I have this problem too.
0 votes
Correct Answer by mahmoodmkl about 7 years 6 months ago

Hi

in which vlan is ur router port connected to.

make sure that u have IP configured according to subnet of that vlan.

and on u r router

add the static routes for u r internal vlan subnets.

ip route 10.10.1.0 255.255.255.0 (ip of the SVI in which the router is connected.

ip route 10.10.20.0 /24 same IP as above

ip route 10.10.30.0/24 same Ip as above.

and on the switch add a default route to the router.

ip route 0.0.0.0 0.0.0.0 (ip of the ethernet interface on the router.)

Thanks

Mahmood

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mahmoodmkl Mon, 05/25/2009 - 02:25

Hi

U can do the intervlan routing on the 3550.

after u create the vlans u need the below config.

cofig#ip routing

switch(config)#interface vlan 1

ip address 10.10.10.2 255.255.255.0

interface vlan 20

ip address 10.10.20.1/24

ip helper-address (ip of the dhcp)

interface vlan 30

ip address 10.10.30.1/24

ip helper-address (dhcp ip)

Thanks

Mahmood

guesswhoiam Mon, 05/25/2009 - 02:56

Thanks for the reply.

I did as you requested. However, i am still unable to ping my router from any of the machines on the network nor i can ping any of the machines from the router.

Is there any other configurtation i am missing?

Correct Answer
mahmoodmkl Mon, 05/25/2009 - 03:29

Hi

in which vlan is ur router port connected to.

make sure that u have IP configured according to subnet of that vlan.

and on u r router

add the static routes for u r internal vlan subnets.

ip route 10.10.1.0 255.255.255.0 (ip of the SVI in which the router is connected.

ip route 10.10.20.0 /24 same IP as above

ip route 10.10.30.0/24 same Ip as above.

and on the switch add a default route to the router.

ip route 0.0.0.0 0.0.0.0 (ip of the ethernet interface on the router.)

Thanks

Mahmood

Actions

This Discussion