Broken RTP stream from IP Cameras via IPSEC or GRE Tunnel

Unanswered Question
May 25th, 2009

I am experiencing very strange behavior of RTP stream from IP cameras (different vendors - D-LINK [cheap] and AXIS [expensive]).

I can get a video from camera in to ways.


1. MJPEG Stream - I use these type of links in Safari or FireFox:

http://admin:[email protected]/video/mjpg.cgi !!!TCP

or !!!TCP

And this is working excellent. The Picture is great. But it consumes a lot of expensive traffic.


2. MPEG4 stream - I use these types of urls in VLC, QuickTime or RealPLayer:

rtsp:// !!!UDP


rtsp:// !!!UDP

Sometime (very seldom and the picture is very unstable) I have a picture and sound, more often I do not see any picture but I hear broken sound.

At the same time the smae MPEG4 stream (rtsp://192.168.x.x:554) is working perfect if I am getting it from local lan PCs (where camera resides). But i have troubles with it outside local LAN (via tunnels).

Here is my net schema:

CAMERA - CAT2950 - C2811-IPSEC VTY via Internet (10 Mbits/s)-C3845-PIX-CAT3750-PC (VLC, QuickTime, RealPlayer)


CAMERA - CAT2960 - C1751V-GRE Tunnel via Internet (10 Mbits/s)-C2621XM-CAT2950-MAC (VLC, QuickTime, RealPlayer).

Also I have very similar schemas - but in all cases RTP is not working.

Something is going wrong with UDP packets during GRE/IPSEC encapsulation. But I do not know what. Please Help.

Thank you.

P.S. here is sample tunnel config, the are all similar :

interface Tunnel80

description IPsec to TOM via Comstar

bandwidth 2000

ip address

qos pre-classify

tunnel source 89.175.xx.xx

tunnel destination 77.236.xx.xx

tunnel mode ipsec ipv4

tunnel protection ipsec profile KM4


interface Tunnel55

description GRE to SKL via Comstar

bandwidth 10000

ip address

qos pre-classify

keepalive 3 3

tunnel source 89.175.xx.xx

tunnel destination 213.33.xx.xx

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Mike Schooley Thu, 03/08/2012 - 08:17

did you get an answer, I'm going to guess fragmentation, but would like to know if you resolved.


This Discussion