Secure Messaging between CUPS7 and UNITY7

Unanswered Question
May 26th, 2009

Hello there, I was working on the integration of CUPS7 and I met one problem with the Failure in "Secure Messaging", which can be seen from the "Show Server Status" of CUPC. However, the Voicemail part seems working well.

In CUPS, I configured the Voicemail Server as my UNITY address with the service HTTPS and port 443, For all these information could be confirmed in CUPC as well.

I enabled SSL on my UNITY and verified by https://unity-ip/exchange and https://unity-ip/web/sa. And, enabled "Encrypt All Messages" in the system configuration as well as the subscribers.

Did I miss something?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
htluo Tue, 05/26/2009 - 08:21

Can you check with a Unity engineer to see if "secure messaging" is enabled?

I'm not a Unity expert. But I think you might confuse the HTTPS with secure messaging.



Gary Tong Tue, 05/26/2009 - 08:48

Thank you, Michael.

I understand the difference between HTTPS and Secure messaging, but just make sure HTTPS communications between Unity and CUPS. From the view of CUPS and CUPC, there is no configuration for Secure messaging.

But how can CUPC verify the "Secure Messaging" is not working?


Tommer Catlin Tue, 05/26/2009 - 08:35

are you using onbox Exchange 2003 or off box Exchange 2003/2007? Either way, the "Secure messaging" aspect of the CUPC client is the IMAP download of the voicemails. So in the CUPC client, it will be requesting IMAP download of the voicemails from the Exchange server (onbox or offbox) You can use secure IMAP ports for this, etc.

Gary Tong Tue, 05/26/2009 - 08:57

Thank you. I'm running onbox Exchange 2003. I will Enbale IMAP Security to test.

Gary Tong Tue, 05/26/2009 - 10:49

I couldn't make CUPC work with Secure Messaging although the Secure Messaging has been configured and when CUPC received the VoiceMail, the promopt said something like "This message is secured and must be listened by Unity Supported Client."

Here is what I did on

UNITY7 Server:

1. In Unity admin, "Message Security Settings" and "Subscribers": Encrypt All Messages.

2. In Exchange IMAP4 "Access Control": Requires SSL/TLS Encryption.

CUPS7 Server:

1. Voicemail Server: UNITY7 IP, 443, HTTPS.

2. MailStore: UNITY7 IP, 993, SSL.

The result in CUPC:

1. VoiceMail: Connected.

2. Secure Messaging: Not Connected - Server Unreachable.


htluo Tue, 05/26/2009 - 12:04

If you're pretty sure secure messaging was enabled on Unity, you should focus on troubleshooting the HTTPS part.

What's the name in the certificate? Was that name being used in CUPS > Unity Server?



Gary Tong Tue, 05/26/2009 - 12:24

Thank you, Michael.

The Name in the certificate is the FQDN name of UNITY7, but I configured IP Address in CUPS -> Voicemail Server. Is it probably the cause?

htluo Tue, 05/26/2009 - 12:38

The name you configured in CUPS has to match the name in the certificate.


Gary Tong Tue, 05/26/2009 - 13:10

Change all VoiceMail relatted address on CUPS to FQDN but "Secure Messaging" still "Server Unreachable".

anyway, thanks a lot.

htluo Tue, 05/26/2009 - 14:30

If that's the case, we need packet capture from the CUPC computer to take a look. Can you get that?



This Discussion