ASA and http redirected traffic

Unanswered Question
May 26th, 2009

situation: I am replacing one of our Firewalls(PIX-515E) with a ASA 5520. All this firewall does is be the front end to most of our WEB/web apps/Citrix traffic. Our main Web pages and sub-web pages all go to our Main Firewall ( PIX-535) and then are redirected to said PIX-515E.

Problem: Everything is working find on the Current PIX-515E, but when replaced with the ASA-5520 the WEB/Web Apps/Citrix traffic Fails.

I have check the configurations ( line by line ) between the PIX and ASA and they are almost Identical.

What is the ASA doing that the PIX is not?


What do I need to turn off/on on the ASA that the PIX is doing automatically?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Kureli Sankar Tue, 05/26/2009 - 11:38

Need more information.

1. What code did the pix515E run?

2. What code is the ASA running?

3. These are web/citrix apps meaning tcp port 80 traffic?

4. Do you have inspect http enabled? If so disable that and see if it works.

5. When you say it breaks what exactly happens? Page doesn't load at all?

What do the logs on the firewall show?

loggin on

loggin buffered 7

sh logg | i x.x.x.x (where x.x.x.x is the ip of the web server)

logan-7 Wed, 05/27/2009 - 05:04

1.Code on pix515E ( 7.2.3)

2. Code on the ASA (7.2.4)

3. The web/citrix apps are using ports 80/443?

4. Pages do not load, and Citrix Apps are not available.

Logging is on, but there isn't any indications in the logs as to why the above issue is happening

I will up load the configs from Both ASA and PIX may be that you will see something I am missing.



This Discussion