availability status doesn't change

Unanswered Question
May 26th, 2009

Hi. So I ran into a problem with CUPC and the status' of users. I went through every item in the troubleshooting guide to try and resolve, but nothing has worked up to this point. The problem is that everyone's status doesn't change when a phone goes off-hook. There are no firewalls in between the CUPS server and CUCM. Server health shows green on the client side and on the CUPS side. I have restarted all services, even bounced the server to no avail. Users are associated to lines, they are licensed, etc. Status is really the only problem I have.

The CUPC devices in CUCM show "not registered" most of the time and I can't figure out why. Any help would be appreciated. Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
mikeduffy13 Wed, 06/03/2009 - 07:54

I'm running 7.x and tracing is on. I have turned on the SIP options for SDI and SDL traces. I'm a little new to reading through traces, so in RTMT what services should be I looking at the traces for?

htluo Wed, 06/03/2009 - 08:02

You should use RTMT > Trace & Log Central > Collect Files to get "Cisco CallManager" logs.

1) Get a phone off-hook.

2) CUCM should send a "PUBLISH SIP" message to CUPS.

If you cannot find "PUBLISH SIP" in "Cisco CallManager" logs, it's the problem on CUCM. Please double-check the CUCM configuration:

1) See if the *line appearance* is associated with end user

2) See if the end user is licensed for CUP

3) See if the SIP trunk was configured properly between CUCM and CUPS.


mikeduffy13 Wed, 06/03/2009 - 09:23

1,2,and 3 are all correct. I should clarify. I am only missing on-hook status at this point. If a person changes their status to away, or is idle, those come through fine to other users. Whenever someone is on the phone however, those changes are never recognized. I am also running this as a "test" environment on VWware if that makes a difference. I will look for the PUBLISH messages in the logs and see what I find.

htluo Wed, 06/03/2009 - 09:30

can you see the PUBLISH message in CUCM traces?


htluo Wed, 06/03/2009 - 19:16

What version is your CUPS?

It looks like the PUBLISH went to the wrong port of the CUPS. It should be heading to port 5070 on CUPS.


mikeduffy13 Thu, 06/04/2009 - 05:41

I am running System version:

I thought on 7.x, 5060 was the correct port? I unchecked the option for Publish SIP Trunk on CUPS and now Presence information is passed fine between everyone...

htluo Thu, 06/04/2009 - 05:55

5060 is for the initial subscription. any subsequent PUBLISH should go to 5070 (PE).

You meant it was working now?


mikeduffy13 Thu, 06/04/2009 - 05:58

Yes it is working when I unchecked this:

Presence->Settings->Enable SIP Publish on CUCM

Not all users are connected to the Presence server yet for some reason, but it is working for the ones that are connected.

andrew.schaefer Fri, 08/07/2009 - 11:23

I have this same exact issue. When the Enable SIP Publish on CUCM is checked it will not show the phone off hook when the handset is lifted. Does this need to be checked for something?


This Discussion