SRW224G4P won't retain settings

Unanswered Question
May 27th, 2009

Hello, we have 3 SRW224G4P, we configure them and they work fine. As soon as there is a power failure they all loose some settings and retain others. I'm lost.

Information lost includes IP address, VLANS, and VLAN settings for ports however if a port is changed from access to general or trunk, this is retained. Any suggestions? Am I missing something?

Config attached.

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
John_Lenehan Mon, 06/15/2009 - 00:41

Hello Cisco / Linksys !!!!!!

I gather by the underwhelming response to this question that the firmware doesn't support saving the configuration and that you must go on site and use the serial interface to configure the switch if it looses power.

If that is the case, the switch is a complete piece of rubbish and should never been put on the market. WARNING DON'T PURCHASE SRW224G4P SWITCHES!



Darren DeCroock Tue, 06/16/2009 - 00:38

John,

It sounds like there is something else going on with these switches.  By default, when the SRW224G4P is configured in the Web UI, those settings are saved to the "running-configuration", and the "startup-configuration".  When the device restarts after a power loss, the configuration will load from the "startup-configuration" file and reload all of its settings, prior to the power loss.

I tested this in our lab, just to make sure, by configuring a switch with a non-standard IP address, a few VLANS, and then unplugging the power cable from the back of the switch while the unit was running.  After plugging the cable back in, the switch rebooted, and all of the settings were restored to their last state before the power loss.

Since your switches are losing their configurations, I would first start with ensuring that the switches are up-to-date with the most current firmware version for that device.  I would also look at the power source for the switches, and if possible make sure that they are connected to a UPS with a conditioned line.  At this point, the only explanation I have is that the switches are receiving a power surge before the power loss, and causing the configurations to become corrupted.

If you have any more information, or questions, please let us know.

Darren

John_Lenehan Tue, 06/16/2009 - 21:15

Hello Darren, thank you for the reply. Attached is the startup-config copied from the switch using the telnet interface. The switches were configured using the web GUI. The firmware versions are

Boot Version:         1.0.1

Software Version:     1.0.2

Loader Version:       1.0.1

Hardware Version:     R01

Which from what I can see are the current release.

When we called Linksys, the response from the Tech was that the switches don't has a reset option so that's how you do a reset. He can issue an RMA but we can expect the new switch to do the same thing. Not a good response.

Just simply turning the power off causes the problem. It doesn't just occur when there is a spike etc.

When the system reboots, there are no VLANS, the IP address is 0.0.0.0 and it has to be set up through the serial interface to give it an IP address. Then use the web interface to define VLANS, set up the management VLAN etc. Wastes hours as the GUI is pretty crap anyway.

Here's the boot up after a power off.

User Mode

--- Performing Power-On Self Tests (POST) ---
DUMMY Test 1 ................. PASS
UART Loopback Test ........... PASS
POE UART Loopback Test ....... PASS
DRAM Test .................... PASS
Timer Test ................... PASS
Done All Pass.
------------------ DONE ---------------------

Loading Runtime Image File : SRW224G4P_SRW248G4P_image.bix
Runtime 1.0.2

Pass
root init done
Set Transition mode ...
[get stackingMac done ret_val] = 1
Assigned Unit ID:[1]
stacking DB: unit = 0, module type = 0
Finish Set Transition mode ...
Enter Transition mode ...
What happens in the lab when you use my configuration?
Darren DeCroock Wed, 06/17/2009 - 00:08

John,

I started to setup and load your configuration in my lab tonight, but found that the SRW224G4P I was using has an older version of the firmware loaded.  We only have one of those units here is the lab, and it was setup and being used by someone on the day shift to recreate another clients issue.

So, I will have to wait until tomorrow night to confirm with whoever is using that switch, that I can upgrade the firmware without interfering with the issue they are trying to resolve.

Before I managed to notice that I was running an older version of the firmware, I did have issues with the IP address resetting to 0.0.0.0 after a reboot.  I don't want to jump to any conclusions at this point, so I will let you know how everything goes after I am able to get the correct firmware version loaded.

Thanks,

Darren

Darren DeCroock Sat, 06/20/2009 - 02:18

John,

Sorry for the delay, I was able to get our SRW224G4P upgraded to the same firmware version you are using.  I then loaded your configuration onto our switch, and then rebooted.  After rebooting, the switch came up with an IP of 0.0.0.0, but did retain a few settings.  It retained 1 of the VLAN's configured.  It also retained some settings for "trunk", "tagged", and "untagged" ports.

I then looked at your configuration file in notepad.  The last thing processed, or saved was the first VLAN you had entered.  The next item was your next VLAN.  The issue is that the name for the second, and third VLANS are using multiple words.  At this time, using VLANS with a name that is two separate words or more, will not be accepted by the switch as a valid VLAN when the switch is restarted.  No error message will be displayed, and the switch will not process the remaining configuration after it encouters the "invalid" VLAN name.

First thing I would like you to try, is to rename your VLANS so that they are all using only one word, with no spaces.

Give that a try, and let me know how it goes.

Thanks,

Darren

John_Lenehan Sun, 06/21/2009 - 16:42

Hello Darren,

No problem with the delay. I'm very grateful to get a result that works!

The effort is much appreciated.

Regards

John

Actions

Login or Register to take actions

This Discussion

Posted May 27, 2009 at 1:44 AM
Stats:
Replies:7 Avg. Rating:
Views:3899 Votes:0
Shares:0
Tags: srw224g4p
+

Related Content

Discussions Leaderboard