Multicast over WAN

Unanswered Question
May 27th, 2009

Hello,

What does i need for enabling Multicast over WAN with OSPF Routing Protokoll. We have a Core with 4500, 6500 Series an Spokes with 3500 Series. We need the Multicast for Ghost imaging.

Sincerely

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4 (1 ratings)
Giuseppe Larosa Wed, 05/27/2009 - 23:22

Hello Niklaus,

you need to enable ip multicast-routing and to configure PIM sparse mode.

PIM can use unicast routing table and it is independent from the routing protocol in use so OSPF is not a problem.

on one core switch you need to use a loopback advertised in OSPF

this has to be used as the RP ip address

RP is the rendez-vous point.

you need on all other devices

ip multicast-routing

ip pim rp address

+

ip pim sparse-mode on all L3 interfaces

for more details see

http://www.cisco.com/en/US/docs/ios/ipmulti/configuration/guide/imc_basic_cfg_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1054581

Hope to help

Giuseppe

n.steffen Thu, 05/28/2009 - 01:27

Hello Giuseppe

Thanks for your answer!

Other question: The Ghost Server reside in a Vlan in the core. can i set the RP to this Vlan ip adress? The command "ip pim sparse-dense-mode" take first the sparse or dense mode?

Thank You

Giuseppe Larosa Thu, 05/28/2009 - 02:34

Hello Niklaus,

ip sparse-dense-mode treats groups as dense if no RP exists for the group and sparse if an RP is mapped for the group.

In your case if you use static mapping as I've suggested you can configure directly ip pim sparse-mode.

If you want to use a dynamic method for advertsing RP mappings (that is good if your internetwork is big) I would use bootstrap protocol instead of auto-RP.

Auto-RP requires ip pim sparse-dense-mode or ip pim autorp-listener to work (because it uses addresses like 224.0.1.39 and 224.0.1.40 to advertise mappings).

Bootstrap protocol uses the bootstrap message sent to 224.0.0.13 and has no issues in a sparse-only domain.

PIMV2 supports BSR (bootstrap protocol) that is also standard.

about source vlan:

you need to enable pim on it.

Recommendation is to use a loopback address to use a logical interface that is up until the node is up.

Hope to help

Giuseppe

Actions

Login or Register to take actions

This Discussion

Posted May 27, 2009 at 10:46 PM
Stats:
Replies:4 Avg. Rating:4
Views:656 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard