Making Corporate Directory numbers dialable

Unanswered Question
May 28th, 2009

CallMananger 7.02 - the 10 digit phone numbers in the corporate directory are from an Active Directory synch. They are not dialable. I want to prepend a 91 in front of these numbers. I tried with Application Dial Rules and Directory Lookup Rules to no avail. Any suggestions? thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Dennis Mink Wed, 06/10/2009 - 16:54

I have a similar issue.

we are using E164 numbering in AD, so australian numbers would be +61XXXXXXXXX.

From CUPC this works like a beaut, because of application rules.

from corporate directory it does not.

I have a translation pattern

61.XXXXXXXXX (discard digits predot and prefix 00). It seems like from corporate directory the + sign is added so +61.xxxxxxxxx is presented to CM resoluting in a failed lookup. Anyone bump into this? and managed to fix it

James Hawkins Thu, 06/11/2009 - 00:45

Not a solution but a possible workaround.

Populate the IPphone field for users in AD and sync to CUCM using that field rather than AD Telephone Number.

Not sure if there is any bulk admin tool for AD that could be used to populate ipphone settings?

Sorry if this is stating the obvious!

Dennis Mink Thu, 06/11/2009 - 02:28

I understand CUCM 7.0 can deal with a + at the beginning of a pattern. Can anyone confirm this?

Kapil Atrish Wed, 06/09/2010 - 04:45

Hi,

Did someone manage to find workaround to this? I've AD integrated CUCM 7.X. I setup up TP as \+818xxxxx. AD is having phone numbers as +81 808 101. Now when I use corporate directory to dial, the call fails saying "Check the number". My TP works fine if I remove \+ and dial it through keypad, confirming Partition and CSS correctly set.

Thanks,

inner_silence

Actions

This Discussion