PPP issue with wic-1adsl in a 2651xm

Unanswered Question
May 28th, 2009

Hi,

I have a 2651XM with a wic-1adsl card in it. I'm trying to configure the card to connect

successfully to my UK ISP, whose ADSL settings are:

VPI=0 VCI=38

RFC2364 PPPoATM VC - Null Encapsulation

Multimode

AutoModulation

I hasten to add I'm very new to this. I've started a config below and it looks like the

ATM interface is exchanging packets but that PPP is negotiating but failing to

authenticate. I want all traffic over the WIC to be routed statically to fe0/0.

Should I change the authentication type from PAP to CHAP?. I expect to see the DHCP assigned

IP address allocated by my ISP assigned to

ATM0/0 but its not assigned, I guess, due to the authentication issue. A pointer or some help

with this would be hugely appreciated. There are some event logs and other pertinent data

attached and I can post anything else thats required.

Thanks in advance,

Pat

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Sam Smiley Thu, 05/28/2009 - 15:19

Hi Pat,

I'll attach a config of a 2620XM with the WIC-1ADSL mosule in it for your reference. This too is accepting DHCP from the ISP. The PVC may be different than what your ISP uses. Check with your ISP for which authentication they use, here in the states I have worked with both CHAP & PAP.

The only difference from this one and yours is that this router has a NM-16ESW installed, anything reference in this config on VLAN 1 will corrispond to your fa0/0.

Cheers,

Sam

Cheers,

Sam

patnliz123 Sun, 06/07/2009 - 14:24

Hi,

Thanks for your suggestion. I think I've managed to connect and authenticate with my ISP and as far as I can see I'm almost there but I can't get my browser

to resolve google just yet. All the config I've put together below was taken at the same time,

except the 'show interface fastethernet0/0' command which I ran as an afterthought following a

router restart, because I felt it would be a good idea to include.

My dialer0 interface is showing the IP address allocated by my ISP, which I guess is a good

thing and both it and the ATM0/0 interface look like they're exchanging packets with my ISP,

which I guess is another good thing. My PC has been allocated a DHCP address by the router and

is attached to it on fastethernet0/0 so I guess the possibilities for the issue are the static

route between the WIC and fastethernet0/0 or the PPP negotiation issue 'Outbound cdp packet

dropped', whatever that is.

The lights on the WIC are in the following state:

CD light is on solid

LP light is off

OK light is on solid

Again, any advice or help on this would be much appreciated. Thanks again in advance,

Pat

Actions

This Discussion