IP Communicator setup for UC520

Unanswered Question


I searched but was unable to find the answers. I am setting up some CIPC clients and I wanted to know where to find any documentation specific to the UC520 setup for these phones (if there is any). The clients see the UC520 but are unable to TFTP the required files off it. I assume I need to load something on the UC520 to support these softphones, but I don't see any docs on what's requried.

Thanks in advance,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Steven Smith Fri, 05/29/2009 - 10:14

It will TFTP a config file, but that is all that it should need.  The phone type in the config would be CIPC.  Are you sure you are having a TFTP problem?  If you think so, please run a debug tftp packet when you startup the phone and post it here.

Steven Smith Fri, 05/29/2009 - 10:34

No, you don't need anything in flash for it. 

What I was referring to was under the ephone type.  It needs to have CIPC.

ephone 4

type CIPC

On the softphone, you will need to point it at the UC500.

One thing to note is that the MAC address you assign on the UC500 needs to match the MAC address you are telling the softphone to use.

Thanks Steve,

That was it I had to go command line on it's phone :D

I needed both the ephone and ephone-dn setup for it to work, now I can test to my hearts content.

For future reference is there docs on this setup?


Steve Di. I posted before you posted your message. WOW! talk about fast documentation! Anyway a couple of notes, I did the same thing via the command line and went back into CCA and verified it's there as well. One thing to note is the Topology view does not show the softphone, might be something you wish to "enhance"


Steven DiStefano Fri, 05/29/2009 - 12:07


I posted that for you after reading your post :-)   So yes, we take Partners seriously here :-)

I also thought it was scalable material as it is a good question).

Regarding topology, I have mine showing up (i just added a pic of it to that above referenced document).

Maybe let CCA refresh to see if you get it too?

Steve D.

Steven DiStefano Fri, 05/29/2009 - 11:34


Great Question.   I scratched my head as well with this and your in excellent hands with Steve Smith.

I played with it to see where its finding the default config file and its not on Flash: proper....

I documented it here:


I just wanted to help demystify it is all.   Hope this is useful.

Steve DiStefano

SE US Field Channels


This Discussion