871W killing connection speed

Answered Question
May 29th, 2009

I have an 871W with IOS 12.4(24)T and Comcast cable internet. When I hook any of my computers directly up to the modem I get speed results anywhere from 1.7Mb/s to 6+Mb/s depending on the site I use for testing. When I connect to the 871W I can't even get close to 1Mb/s speeds on any sites. My duplex and speed on both WAN and LAN ports is 100/full. I have a bare minimum config on the router so that all it can do is move data from LAN to WAN. Wireless interface is turned off.

Anyone have any clue what the router is doing to kill my connection?

I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 7 years 7 months ago

Please configure:

no ip source-route

interface FastEthernet4

no ip virtual-reassembly

interface Vlan1

no ip virtual-reassembly

no ip nat inside source route-map NAT interface FastEthernet4 overload

ip nat inside source rlist NAT interface FastEthernet4 overload

Failing that you ma want to look to switch a different IOS, eg 12.4(3j) or so.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joseph W. Doherty Sat, 05/30/2009 - 03:18

"My duplex and speed on both WAN and LAN ports is 100/full."

Are all the ports configured auto/auto and they negotiate 100/full, or are some hard coded 100/full? If the latter, do all the hosts have matching port configurations (i.e. hard coded to hard coded, not auto to hard coded)?

Correct Answer
Paolo Bevilacqua Sat, 05/30/2009 - 09:08

Please configure:

no ip source-route

interface FastEthernet4

no ip virtual-reassembly

interface Vlan1

no ip virtual-reassembly

no ip nat inside source route-map NAT interface FastEthernet4 overload

ip nat inside source rlist NAT interface FastEthernet4 overload

Failing that you ma want to look to switch a different IOS, eg 12.4(3j) or so.

jasonww04 Sat, 05/30/2009 - 11:28

I changed everything except for the ip nat statement and it worked. Thanks.

Joseph W. Doherty Sat, 05/30/2009 - 09:45

"interface FastEthernet4

ip address dhcp

ip nat outside

ip virtual-reassembly

speed 100

full-duplex"

So this port is connected to a cable modem? If so, cable modem is configured 100/full?

Can you provide show interface stats for your active interfaces?

Actions

This Discussion