SPA9000 - Cannot Connect

Unanswered Question
May 30th, 2009


I have a SPA9000 that I can't connect to, either using the configuration wizard or through the device's web GUI.

The setup wizard fails to find or connect to the SPA9000.

It gets a DHCP assigned IP address and responds to a ping. I've scanned the device using NMAP and all ports appear to be closed.

The status (amber) light is on permanently and so is the phone 2 (green) light.

The SPA9000 hasn't been used in a while so I guess it must have a firmware version 5.*, but definitely not v6.

I understand that there is a recovery tool but  haven't been able to find this.

Any suggestions or help would be appreciated.

I don't have any access to an anlog phone to connect and try a factory reset.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Patrick Born Mon, 06/01/2009 - 12:37


You need an analog phone. This is just a simple phone with a RJ11 connector. This is the type of phone that can be found anywhere...

If web access has been shut off on the SPA9000, the only way you will get into the SPA9000 is with an analog phone to access the device's integrated voice response [IVR] system.

Contact me at paborn at and I will send you the recovery utility for the SPA9000 v1, but you'll save yourself a lot of time and effort by using an analog phone.




agnetman Mon, 06/01/2009 - 14:17

Hi Patrick,

I managed to borrow an analog phone today and used it to access the IVR on the SPA9000. I dialed **** followed by 73738#, which I understood to be the method to reset the device to its factory default settings.

After the SPA9000 rebooted it again received network settings through DHCP and using Wireshark I can see that when an attempt is made to open the web GUI the SPA responds with FIN, RST and ACK.

Could it be that it may take several attempts to reset the SPA9000 correctly? Will the recovery utility be of any use in the scenario that I'm experiencing?

Many thanks.

Patrick Born Mon, 06/01/2009 - 15:04


I'm glad that you were able to procure an analog phone. You've proved that your SPA9000 still has life in it by accessing the IVR and factory resetting it.

One reset is enough to do the trick. The recovery utility is only of use if an upgrade fails for some reason such as network/power outage and the SPA9000 cannot be properly booted.

Please try the following:

  1. Analog phone dial **** [you will not hear dial tone, but will hear "Linksys configuration menu" when you reach the IVR]
  2. 73738 follow prompts to reset
  3. After SPA9000 has booted again [~20 seconds]
  4. Analog phone, dial **** to access IVR
  5. Dial 110 to obtain IP address
  6. Dial 7932 to enable WAN access to admin interface
  7. Use browser to access SPA9000 as follows: http:///admin/advanced example:

You should now have full control of the SPA9000.

Please let me know of any progress.




agnetman Wed, 06/03/2009 - 14:18

Hi Patrick,

I haven't been able to try anything since your last post until today.

I followed your instructions but there was no change.

What I have tried since and has worked is the following.

After entering **** and accessing the IVS I entered 7932 and was prompted to enter a value, I chose 1 then saved with another 1, trying the web GUI again worked!

I have access now.

Thanks for your help and patience.

agnetman Wed, 06/03/2009 - 14:39

I need to ask for help with another issue now on the same device.

It has software version 3.2.5(c) and when I try to upgrade using upg-spa9000t-6-1-5.exe it fails.

I've also tried upgrading to 5.2.5 but this also fails, the process appears to proceed but on completion returns the error message upgrade failed, version not matching.

If it helps any Hardware Version:1.0.0(580a)

Patrick Born Wed, 06/03/2009 - 16:50

Great. I'm pleased that you were successful with upgrading the SPA9000's firmware.




Patrick Born Wed, 06/03/2009 - 16:48


Thanks for letting me know. I'm glad that it's now accessible.




abubakarsaeed Mon, 07/05/2010 - 22:59


I am a begniner with SPA 9000 in a lab environment with SFE1000P and a single SPA 525G, to beginwith i am unable to get the configuration wizard connect to the SPA9000, whenever i attempt it give me an error saying SPA 8000 has recently been factory reset please wait a while for it to settle down and try reconnecting later.

I am able to reach the webinterface of the SPA from Webinterface and assigned it a fixed IP Address as well since i do not have a DHCP setup, furthermore i am also unable to get the SPA 525G connect though i have assigned a fixed IP to SPA9000 as well.

Can i know which is the latest version of configuration wizard to run? and is there a screen shot reference guide to configure the SPA9000 in order to make it work?

Please excuse my ignorance as i am new to Cisco SB and IP Communications in general.

rafaelpedraza Mon, 11/02/2009 - 19:32

I have a similar problem.  I performed a factory reset to the spa9000 and now I can not see it.  I have check the ip address with the analog phone using the 110# and indicate the ip adress is    How can I change the ip address thru the analog phone?  can anyone help me?


mihagan Mon, 11/02/2009 - 20:04

Using code 110 in the IVR should give you a WAN IP address and if it is currently not connected to anything providing DHCP addresses then it should be If you need the LAN IP address of the SPA9000 you should enter code 210 instead.

Here is the administration guide for the SPA9000.

You can find information on using the IVR starting on page 40.


rafaelpedraza Tue, 11/03/2009 - 06:54

Thanks Michael. All IP adresses in the network are static probably that is why the SPA9000 didn´t get one, but I finnaly found how to enter an IP address manually the code is 111# thru the analog phone.   Now I can see the SPA9000, but can not see the SPA400, do you know how can I enter an IP address manually to the SPA400?


jshults Thu, 11/05/2009 - 09:37

You need to connect the SPA400 to some network where a DHCP server exists.

Then let it get an address and check the DHCP list on the DHCP server.

Connect to the SPA400 via Web Page and then adjust the setting to use static IP.


This Discussion