HQF Shaper Backg + Dot11 driver = 50%+ proc time ... at iddle

Unanswered Question
May 30th, 2009

I have a router in iddle mode; ie: all interfaces are shutdown, and even then I am seeing high CPU loading

I am not using HQF at all, I just learned what it is seeing the following cpu output.

I want to use the radios but even while they were shutdown for the last 30 minutes I see the driver eating 20% cpu time ... steady.

This problem became apparent while working on the console; very unresponsive, eg: I hold a key and I see huge delays.

Cisco CP takes eons to complete the discovery process of just this router entered by IP.

show processes cpu sorted 5min:

CPU utilization for five seconds: 88%/0%; one minute: 84%; five minutes: 57%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

153 55316 5886 9397 28.26% 28.31% 14.01% 0 HQF Shaper Backg

66 39848 3952 10082 19.69% 19.73% 9.82% 0 Dot11 driver

197 10156 1090 9317 5.04% 4.88% 2.46% 0 Atheros LED Ctro

3 8576 663 12935 9.36% 4.38% 2.05% 194 SSH Process

... question are obvious:

what the hell is HQF doing here when I not configured anything associated with it ?

why am I seeing a 20% steady load on the dot11 driver if the interfaces are shutdown ?

C1841v03 (128 MB + 256 MB) with HWIC-AP-AG-A installed

c1841-advsecurityk9-mz.124-22.T.bin

upgraded ROMmon to c1841_RM2.srec.124-13r.T5

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nlariguet Sun, 05/31/2009 - 18:43

I'm starting to figure out what is happening; just found the following:

QoS is disabled by default; however, the radio interface always honors tagged 802.1P packets even when you have not configured a QoS policy.

Which explains why I am having those processes running but I am not able to figure out why they take 50% CPU load.

How can I completely disable said QoS on a radio interface ?

Actions

This Discussion