How to advertise NATed IP to peer via BGP

Unanswered Question
May 31st, 2009

Hi everyone

May be my problem is very small for most of u people but iam badly stuck with it. any kind of help will really be appreciated

I have my private IP which i cant advertise to MPLS cloud as my remote sites also have same private IP so i NATed it into some other IP and now i want to advertise it to cloud via BGP but it is not advertising it. My router only advertises directly connected IPs or those IPs being learned from IGP but not my virtual NATed IP. here is my important part of code


interface FastEthernet0/0

ip address

ip nat outside

interface FastEthernet0/1

ip address

ip nat inside

router bgp 65021

bgp router-id

bgp log-neighbor-changes

neighbor remote-as 64517

address-family ipv4

redistribute static

neighbor activate

no auto-summary

no synchronization

network mask


ip nat inside source static network /24


If i write instead of while configuring network for bgp, it advertises it but i don't want 8.0 subnet to be advertised. I want 171.0 subnet advertisement.

Any suggestions??

i would be really thankful for any kind of help



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jon Marshall Sun, 05/31/2009 - 11:41


Add this to you router config

ip route Null0

For a EBGP peer to advertise a route it must be in the IGP routing table. You don't have that but you are redistributing static so if you add the above static route it will be advertised out.


shahzadliaqat Sun, 05/31/2009 - 18:56


Thank you so much. It has straight away advertised it after i add your mentioned static route. I have been struggling with it since yesterday but u just solved the problem in one click. thanks for your help




This Discussion