how can I disable (default enabled) QoS on a radio interface ?

Unanswered Question
May 31st, 2009
User Badges:

I have 50% CPU load with all interfaces shutdown and I see the are two processes (dot11 driver and HQF).


I just learned HQF is QoS related:


QoS is disabled by default; however, the radio interface always honors tagged 802.1P packets even when you have not configured a QoS policy.


so question is ? how can I disable QoS on said interface ?


C1841 with 384 MB and HWIC-AP-AG-A

c1841-advsecurityk9-mz.124-22.T.bin


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nlariguet Fri, 06/05/2009 - 06:51
User Badges:

I appreciate your answer ... however you are answering me with the same exact line that is posted in my question so frankly I don't understand what's the point of your answer at all.


By the way I just fixed the problem myself a couple of days ago.


Thanks anyway.


Robert.N.Barrett_2 Mon, 06/08/2009 - 03:24
User Badges:
  • Bronze, 100 points or more

Just curious - what did you do to fix the problem? Also, I'm not sure what the actual problem was - were you concerned about wasting CPU time on a service you did not need?


nlariguet Mon, 06/08/2009 - 08:43
User Badges:

Not actually. I was running 12.4 mainline without any problems for a almost a year. A month ago I bought an HWIC-AP-AG-A which I needed to run on station-role non-root; ie: the universal client mode.


Upon installation of the module on my C1841 I realized I was needing to upgrade to a T image to enable it since mainline didn't detect the interface at all so there I went to 12.4.22T and this is where my problems started: the router went very very unresponsive even from a console connection including exasperating delays while typing a simple command.


I started to investigate a bit and I noticed two processes consuming more than half the CPU power: dot11 driver and HQF which I later realized had to do something with QoS. Since I don't need this feature at all ... thus my question to begin with because these two processes with 50%+ CPU load didn't feel quite right to me at the time.


After diving into many configuration guides and command references and lacking any answers on how to disable said service, a week ago I went with my configuration disabling one line after another and issuing sh processes cpu after each one and voilá; my mainline config included the following three lines:


no exception memory ignore overflow processor

no exception memory ignore overflow io

no scheduler heapcheck process memory processor io


Everything returned normal after deleting these lines on the T image.


These commands were placed a year or so ago following recommendations by a Cisco guide on hardening routers which I don't remember the exact name but I can look for it if needed since I know I have it somewhere on my drives.


So that's it.


Actions

This Discussion