phone auto registration on the Sub

Unanswered Question
Jun 1st, 2009
User Badges:

Hi,


I have a ccm7 pub sub cluster and found out that auto-registration and tftp does not work for phone registration on the SUB.


The error messages are that it can't find the tftp file and ultimately will result in registration rejected.


If I point the tftp server back to the PUB it will obviously work without any problems.


Just wondering if anyone came across such a similar scenario.


I came across some blogs that mentioned this, however no one seems to be sure whether auto-registration and tftp server works on the SUB.


Tftp service on the SUB is definitely started.


Any help appreciated.


Thanks,

Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Mon, 06/01/2009 - 13:02
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

You can go to the TFTP service parameters and rebuild all files, restart TFTP and try again.


If you enable TFTP and autoregistration on SUB there is no reason not to work.


Enough DLUs?

The CUCM version has support for the phone model you're using?


Have you tried a cluster reboot or restarting the DBL at least?


HTH


java


if this helps, please rate

PAUL CHEN Mon, 06/01/2009 - 15:18
User Badges:

I tried rebuilding all files in service parameters and I no longer have the missing files error message.


However, i still see 'registration rejected' right after the 'defaulting cm to tftp server message'


It is the same error for both auto registration and manual registration. The 7960 gets an ip address from the SUB but it does not register.


When I checked the active log files, some ccm0000000x.txt files I do not see any error messages or any attempt to register the 7960 phone.


Any more ideas ?


Thanks.

Jaime Valencia Mon, 06/01/2009 - 18:57
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

You should see an error in the application log for this, there are some more details there that could help


That message means the phone tried with all 3 possible CUCMs from CUCM group and now it's trying to register at the TFTP address.


Are CUCM services running?


HTH


java


if this helps, please rate

MARTIN STREULE Tue, 06/02/2009 - 04:40
User Badges:
  • Silver, 250 points or more

Check the CCM Group in the Autoreg device pool.

This has to point to the subscriber if you have autoreg enabled there.


/Martin

PAUL CHEN Tue, 06/02/2009 - 09:30
User Badges:

Thanks. I finally got phones to register to the Sub and Pub as well.


I selected 'built all' in the tftp service parameters pull down menu. How and where can you see that it has been built ?


I pointed the tftp server to the sub ip address and set the server parameter to false.


Registration is still rejected until I place the Sub at the top followed by the Pub below in the Cisco Unified CM Group pull down menu Selected UC Mgrs box. Is this why it did not work ?



Now that I got it to register with the Sub, I still see 'file not found Sep...'

but then the phone will register after this message, it is slow but it works.


Thanks again


PAUL CHEN Tue, 06/02/2009 - 09:56
User Badges:

Thanks,everyone. I finally got the phones to register to the Sub and Pub as well.


I selected 'built all' in the tftp service parameters pull down menu. How and where can you see that it has been built ?


I pointed the tftp server to the sub ip address and set the server parameter to false.


Registration is still rejected until I place the Sub at the top followed by the Pub below in the Cisco Unified CM Group pull down menu Selected UC Mgrs box. Is this why it did not work ?



Now that I got it to register with the Sub, I still see 'file not found Sep...'

but then the phone will register after this message, it is slow but it works.


Thanks again


Actions

This Discussion