NSS4000 doesn't let upgrade its firmware

Unanswered Question
Jun 1st, 2009
User Badges:

Hello,

my NSS4000 was running on an older firmware than currently available. As I tried to upgrade it through the described procedure, it would show a message like 'Firmware image was changed, its running from backup' after its rebooted.

Even after several upgrades, its always showing the same message and coming up with the old image.


Is there a way to force the update?


Regards

Wolfgang

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
clindoan Wed, 06/03/2009 - 14:22
User Badges:

Wolfgang- The release note said  that you need to allowed for approximately 10-12 minutes for the upgrade. You can unplug the power cord and replug back in for the upgrade firmware to take effect. Also, there are two banks in the memory to store the firmware, one is idle and another is active. The upgrade is for only the idle firmware and system will boot with the latest firmware (latest version number) and put another idle. Make sure you upgrade twice to have both banks on latest firmware.

wrank Thu, 06/04/2009 - 07:19
User Badges:

Hello Clint,

I just tried everything noted in the release notes. It is always coming up with the message 'Firmware image has been switched, you are running off a backup firmware image.' Did try everything, unplug after update or restart through the web interface. Never get the new image loaded.

May be the messages displayed on the browser during upgrade can help:


Updating Firmware image
Upon successful programming the NAS will be rebooted
Stopping services:
+_dagent
+_crond
+_winbind
+_samba
+_upnpd
+_ypbind
+_httpds
+_vsftpd
+_nfs
+_ups
+_dropbear
+_portmap
+_ntpd
+_aggregation
All requested services are stopped.
Current approximate RAM usage: [13484]kB
Start: Receiving data from /tmp/fwpipe...
Received all data from /tmp/fwpipe, checking its validity...
New firmware version is [154]
Old firmware version is [086]
Received valid data, starting programming process...
Dumping rw partition upgrade into [/linuxrwfs/update.d/confupdate]...
Extracting [confupdate.tar.gz]...
Creating [/linuxrwfs/update.d/confupdate] dump point...
Dumping [confupdate.tar.gz] content into [/linuxrwfs/update.d/confupdate]...
confupdate.tar.gz successfully programmed.
Erasing rootfs from [/dev/scsibd4]...
Extracting and programming rootfs...
Block size is [131072], programming [/dev/scsibd4]...
rootfs successfully programmed.
Extracting and programming kernel...
Block size is [131072], skipping [1999] blocks...
vmlinux successfully programmed.
Transfering current settings to upgraded partition...
Setting up bootline...
Setting bootstate to B0...
Unsetting bootcount...
Warning: couldn't unset bootcount.
Firmware update succeeded. The system will reboot now.



What can I do?

Regards

Wolfgang

clindoan Thu, 06/04/2009 - 11:45
User Badges:

Hi,

  I just received your responsel. The log captured is a successfully upgrade.  It looks everything was good to me. The reason the unit is still running I am suspecting is while it was upgrading, you or may be someonw were access or working on the active FW which allowed to keep the current FW active. You may try to upgrade again from current firmware. Steps I would do:

- Current running FW= ?????? V1.12.3 or ealier version

1) Clear out (delete all logs) - this is just to make sure that before upgrade you have the clean log to keep track of the new action (upgrade)

2) Start upgrade from the GUI (Admin => Maintenance => (Browse to location of FW V1.14.XX)

3) Click to upgrade

4) ***DO NOT ACCESS TO THE NSS GUI**** while it is upgrading. (This could interupt the auto upgrade process to be boot on the new firmware)

  Note: While it is upgrading, if the current operating FW still can be access and do normal thing from the GUI. If this is happen, the transition to boot on new upgraded FW won't happen.

Observe: Let the upgrade process. after 12-15 minutes from the time you clicked the Upgrade button. Just power recycle the unit. You would see the NSS running on latest FW.


Let me know how it goes.

wrank Thu, 06/04/2009 - 15:15
User Badges:

Hi Clint,


doesn't help anyhow. Did all you told, but it still doesn't upgrade the firmware. Here is the admin log:


2009-06-04 23:56:28 The last NAS Shutdown was not clean
2009-06-05 00:10:01 NAS Firmware image has been switched
2009-06-05 00:10:01 The last NAS Shutdown was not clean


So I did unpower the unit after it told, that it is rebooting after firmware upgrade. It does bring always the same error message.


Cheers

Wolfgang

clindoan Mon, 06/22/2009 - 11:15
User Badges:

Hi Wolfgang,

    Have you call anyone from Technical Support to help you out yet ?  You may setup this unit (without disks) to internet and have someone to access to see what is the problem and they are able to get this done for you. I would be able to help you out as well.  The techincal person will open a ticket and they will escalate the issue and help you out.


Regards.

Actions

This Discussion