Traffic going via BGP link and returning traffic via Eigrp link

Answered Question
Jun 2nd, 2009
User Badges:

Hello GS,


Please help me in the below scenario.


I have a 100mb link configured with BGP and 2MB link configured with Eigrp.


Scenario1:- Since 100mb is a big BW, I want the return traffic also to come from the same BGP 100 mb link.


Scenario2:- In few cases I observed few destinations are going via BGP link and fe via Eigrp link.



Below is configuration and trace route report:-

MUHC WAN Router:-


interface GigabitEthernet0/0

description To Internal LAN Network Ghussais

ip address 10.121.254.1 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/1

description TO IP_CONNECT MPLS - 123456

ip address 10.241.121.1 255.255.255.252

duplex auto

speed auto

interface BRI0/0/0

no ip address

encapsulation hdlc

shutdown

interface Serial0/1/0

description 2 mbps LL to HQ - 1234567

bandwidth 2000

ip address 10.240.121.2 255.255.255.252

encapsulation ppp

router eigrp 1

network 10.121.0.0 0.0.255.255

network 10.240.121.0 0.0.0.255

network 10.241.121.0 0.0.0.255

no auto-summary

router bgp 121

bgp log-neighbor-changes

neighbor 10.241.121.2 remote-as 64517

!

address-family ipv4

neighbor 10.241.121.2 activate

no auto-summary

no synchronization

network 10.121.0.0 mask 255.255.0.0

exit-address-family

!

ip route 0.0.0.0 0.0.0.0 10.240.121.1

ip route 10.1.0.0 255.255.0.0 10.240.121.1

ip route 10.121.0.0 255.255.0.0 10.121.254.2



Branch office - MUHC2851-Router# traceroute 10.1.254.1 ( Head office IP)


Type escape sequence to abort.

Tracing the route to 10.1.254.1


1 10.240.121.1 64 msec 80 msec 8 msec

2 10.1.250.1 12 msec 648 msec 108 msec


Branch office - MUHC2851-Router# traceroute 10.15.254.1 ( another BO IP)


Type escape sequence to abort.

Tracing the route to 10.15.254.1


1 10.240.121.1 8 msec 16 msec 180 msec

2 10.1.250.200 544 msec 20 msec 24 msec

3 10.240.16.2 104 msec 624 msec 120 msec

4 10.15.250.1 216 msec 64 msec *



Branch office - MUHC2851-Router# traceroute 10.8.254.1 ( another BO IP)


Type escape sequence to abort.

Tracing the route to 10.8.254.1


1 10.241.121.2 4 msec 0 msec 0 msec - ----- please look at HOP1

2 * * *

3 10.241.8.1 [AS 64517] 0 msec 0 msec 0 msec

4 10.8.251.2 [AS 8] 4 msec 0 msec 4 msec

5 10.8.254.253 [AS 8] 4 msec 0 msec *

Branch office - MUHC2851-Router# traceroute 10.44.254.1


Type escape sequence to abort.

Tracing the route to 10.44.254.1


1 10.240.121.1 8 msec 12 msec 20 msec ----- please look at HOP1

2 10.1.250.1 12 msec 8 msec 8 msec

3 10.43.250.33 [AS 43] 8 msec 8 msec *

+++++++++++++++++++++++++++++++++++++++


MUHC -Core switch:

interface Vlan252

ip address 10.121.252.1 255.255.255.0

interface Vlan254

ip address 10.121.254.2 255.255.255.0

router eigrp 1

network 10.121.3.0 0.0.0.255

network 10.121.10.0 0.0.0.255

network 10.121.50.0 0.0.0.255

network 10.121.101.0 0.0.0.255

network 10.121.102.0 0.0.0.255

network 10.121.103.0 0.0.0.255

network 10.121.201.0 0.0.0.255

network 10.121.202.0 0.0.0.255

network 10.121.252.0 0.0.0.255

network 10.121.253.0 0.0.0.255

network 10.121.254.0 0.0.0.255

network 10.121.0.0 0.0.255.255

no auto-summary

+++++++++++++++++++++++++++++++++++++++++++

Return Traffic from otherBranch office & HQ locations to MUHC BO :-


TUHC_6513_CS1 IP_10.44.254.1#traceroute 10.121.254.1 ( MUHC BO IP)

Type escape sequence to abort.

Tracing the route to 10.121.254.1


1 10.43.250.34 0 msec 0 msec 0 msec

2 10.1.250.50 [AS 1] 0 msec 0 msec 0 msec

3 10.240.121.2 12 msec * 20 msec


DUHC_6509_CS1_10.8.254.1#traceroute 10.121.254.1 ( MUHC BO IP)

Type escape sequence to abort.

Tracing the route to 10.121.254.1


1 10.8.250.1 0 msec 0 msec 0 msec

2 10.240.8.1 12 msec 16 msec 16 msec

3 10.1.250.50 16 msec 8 msec 8 msec

4 10.240.121.2 8 msec * 4 msec


HQ_6513_CS1_10.1.254.1#traceroute 10.121.254.1

Type escape sequence to abort.

Tracing the route to 10.121.254.1

1 10.1.250.50 0 msec 0 msec 0 msec

2 10.240.121.2 8 msec * 8 msec



Thanks in advance,

Mirza.




Correct Answer by Giuseppe Larosa about 7 years 9 months ago

Hello Mirza,


>> If i does summarization in Eigrp does it works when my BGP link goes down?


yes exactly as the BGP aggregate


>> Assume if i only publish router summarization in EIGRP and BGP then route selection wil be done on AD vlaue?


yes with eBGP preferred over normal EIGRP routes, some tuning is needed for EIGRP summary routes (lowest is better eBGP AD=20 EIGRP AD=90: note EIGRP summary route have AD 5 you may need to add an AD greater then 20 at the end of the ip summary-address eigrp interface command; )


>> basically i am looking to avoid typing so many more specific routes in BGP


to avoid this you can redistribute EIGRP into BGP at WAN HQ router


Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
mirzaakberali Tue, 06/02/2009 - 03:12
User Badges:

Further info is at MUHC


BGPlink subnett is 10.241.121.0

Eigrp link subnett is 10.240.121.0.


I see abnormality in return traffic and also forwarding traffic.

Giuseppe Larosa Tue, 06/02/2009 - 04:58
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mirza,

the WAN router is advertising net 10.121.0.0/16 in eBGP to branch office.


Be aware that the most specific prefix is used regardless of Administrative distance.


So if branch office receives more specific routes from another path via EIGRP it will use it.


To achieve the desired behaviuor you can do


use ip eigrp summary address to have only 10.121.0.0/16 advertised to branch office in EIGRP


Edit:

it has to be used on an interface on the path to branch office


OR


you need to advertise all the detailed routes in eBGP

you can achieve this with on the WAN router with:

router bgp 121

address-family ipv4 unicast

redistribute eigrp


Hope to help

Giuseppe


mirzaakberali Tue, 06/02/2009 - 19:50
User Badges:

HEllo Giuseppe ,


Thank you for the nice explanation.


If i does summarization in Eigrp does it works when my BGP link goes down?


Do i need to publish all my more specific routers in BGP .


Assume if i only publish router summarization in EIGRP and BGP then route selection wil be done on AD vlaue?


basically i am looking to avoid typing so many more specific routes in BGP .

any scenario or link for the more explantion.


once again thanks for your explanation.


Regards,

Mirza.

Correct Answer
Giuseppe Larosa Tue, 06/02/2009 - 21:27
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mirza,


>> If i does summarization in Eigrp does it works when my BGP link goes down?


yes exactly as the BGP aggregate


>> Assume if i only publish router summarization in EIGRP and BGP then route selection wil be done on AD vlaue?


yes with eBGP preferred over normal EIGRP routes, some tuning is needed for EIGRP summary routes (lowest is better eBGP AD=20 EIGRP AD=90: note EIGRP summary route have AD 5 you may need to add an AD greater then 20 at the end of the ip summary-address eigrp interface command; )


>> basically i am looking to avoid typing so many more specific routes in BGP


to avoid this you can redistribute EIGRP into BGP at WAN HQ router


Hope to help

Giuseppe


mirzaakberali Wed, 06/03/2009 - 00:06
User Badges:

Hello Giuseppe ,


Thanks you so much for the gr8 explanation.


Let me follow these instructions at my locations and see the results today.


Thanks, Mirza.

Actions

This Discussion