×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

BGP sessions timeout over port channel Layer 2

Unanswered Question
Jun 2nd, 2009
User Badges:

Hi,

I have one router (CISCO7609-S) and had configured one port channel with 2 Gig interfaces.when I put no shutdown the second interface the BGP sessions fall down by timeout after 3 minutes(BGP flapping).

The interfaces are in the same module.


Version 12.2(33r)SRC3


interface Port-channel256

description CONEXION con TASA IPCUY02 - Cuyo

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 458,459

switchport mode trunk

mtu 9216

logging event link-status

logging event trunk-status

logging event bundle-status

logging event spanning-tree

!

interface GigabitEthernet1/47

description CONEXION #2 A DWDM-TASA G5/4 <-> Router TASA IPCUY02

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 458,459

switchport mode trunk

mtu 9216

logging event link-status

logging event trunk-status

logging event bundle-status

logging event spanning-tree

channel-group 256 mode active

!

interface GigabitEthernet1/48

description CONEXION #1 A DWDM:VLE5200-02-slot1-port1-TASA - G3/1 <-> Router TASA IPCUY02

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 458,459

switchport mode trunk

mtu 9216

logging event link-status

logging event trunk-status

logging event bundle-status

logging event spanning-tree

shutdown

channel-group 256 mode active

!



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Amit Singh Tue, 06/02/2009 - 04:44
User Badges:
  • Cisco Employee,

Please paste your L3 and BGP configs from both the sides.



Giuseppe Larosa Tue, 06/02/2009 - 05:14
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mario,

during this time when you try to add the second member link are you able to ping the BGP endpoint ?


my guess is that something happens on the bundle.

It could be a good idea to do the following:


shut both member links

use interface range to perform a no shut


Other collegues have reported in other threads that timing is a key factor on LACP negotiated bundles


Hope to help

Giuseppe


m.arancibia Tue, 06/02/2009 - 05:52
User Badges:

Hi Giuseppe,


Yes, during this time our customer was able to ping.


Is dificult to shut this interfaces because the router is in production.


Thanks a lot.


Giuseppe Larosa Tue, 06/02/2009 - 06:38
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mario,

to reproduce the BGP flow also the source should be the same as in the BGP session


if it is already so I don-t understand what is the issue.


For testing what I have suggested before you need to ask for a maintanance time window


Hope to help

Giuseppe


m.arancibia Tue, 06/02/2009 - 06:53
User Badges:

Hi Giuseppe,


I already suggested the same to our customer.

The info is poor to begin a good troubleshooting.


Regards

m.arancibia Tue, 06/09/2009 - 06:32
User Badges:

finally de problem detected is that the BGP sessions are closing by time out. In both sides are registering the same message...


BGP: 200.63.150.229 connection timed out 180940ms (last update) 180000ms (hold time)


The port-channel not have errors.


Actions

This Discussion