Cannot add VLAN to GigabitEthernet on 3825

Unanswered Question
Jun 2nd, 2009

We have a 3825 running IOS (C3825-ADVIPSERVICESK9-M), Version 12.4(25), RELEASE SOFTWARE (fc2). We have a number of VLANs defined, and several FastEthernet ports are members of them.

When I attempt to add GigabitEthernet 0/1 to a VLAN, it fails with the error:

3825-B-Geno#conf t

Enter configuration commands, one per line. End with CNTL/Z.

3825-B-Geno(config)#interface GigabitEthernet 0/1

3825-B-Geno(config-if)#switchport access vlan 714


% Invalid input detected at '^' marker.

This same command works perfectly on any of the FastEthernet ports.

I don't see trunking enabled:

3825-B-Geno#sho int GigabitEthernet 0/1

GigabitEthernet0/1 is down, line protocol is down

Hardware is BCM1125 Internal MAC, address is XXXX.XXXX.XXXX (bia XXXX.XXXX.XXXX)

Description: Foo

MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Unknown duplex, Unknown Speed, media type is RJ45

output flow-control is XON, input flow-control is XON

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

0 packets output, 0 bytes, 0 underruns

3 output errors, 0 collisions, 2 interface resets

0 unknown protocol drops

0 babbles, 0 late collision, 0 deferred

3 lost carrier, 0 no carrier, 0 pause output

0 output buffer failures, 0 output buffers swapped out

How can I get this interface to join the VLAN?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
a.cruea1980 Tue, 06/02/2009 - 07:08

The GE ports on a 38xx are not switch ports, but router ports. The "switchport access vlan" statement won't work on them.

Instead, you have to create subinterfaces on them.

In the G0/1 interface config, you'd issue the "no ip address" command, then create a subinterface with "int g0/1.714" (you can use whatever number you want, though, but it's common to use the vlan number).

You'd then use "encapsulation dot1Q 714" if you're using 802.1q VLAN encapsulation, then assign it an address in that VLAN.

When you do that, then the switch port you're plugging into it has to have trunking enabled on it.

Basically, it's a "router on a stick" config.

Hope that's what you're looking for.


This Discussion