Limit an IP address in layer 2

Unanswered Question
Jun 2nd, 2009


I need to assign a public IP address to a host but I want to be sure that he uses the correct one, and if not then deny traffic from other IPs. The host connects through a fiber link to a 6500 which does not support port ACLs so we tried another solution using a 2950 that supports inbound ACLs in the interfaces.

The connection was the following:

host(access vlan 50) <---> (access vlan 50)6500 (trunk with allowed vlan 50) <---> (trunk with allowed vlan 50)2950(port 2 access vlan 50) <---> (port 3 access vlan 51)

VLAN 50 was created for their public IP address and VLAN 51 is the real public VLAN where the ISP has the default gateway. There is a "loop" as you can see that connects and access port in VLAN 50 with another access port in VLAN 51. On this port we configure the ACL inbound so we limit to only the assigned IP address. We also enabled bpdufilter in order to avoid STP disabling a port.

When we connected the config in a lab, everything worked fine and the only error that appeared was related to the VLAN mismatch that of course is happening as we are connecting two collision domains together.

The problem is that when we connected it on the real network, a broadcast storm was created and we had to disconnect it.

I have two questions then:

What could be the reason of the broadcast storm?

Is there another way to do this?

I hope I explained the problem, if not please ask.

Thanks a lot,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
fabianalfaro Tue, 06/02/2009 - 12:52

Just an update. I was able to find what was the problem: the access ports had configured the same "switchport voice vlan" so it created a loop which originated the broadcast storm.


This Discussion