BARS install fails on CCM 4.0.2 - Error 1603 msiexec.exe

Unanswered Question

I am trying to upgrade BARS to 4.0.14 on a CCM 4.0(2a)sr3c Publisher. The publisher previously had BARS 4.0.6 installed which was working fine. As part of the BARS 4.0.14 install, it uninstalls the previous version and attempts to install 4.0.14. All appears to go well (set it as Backup Server and enter a Backup Server admin password, files are copying) and then the install suddenly goes into rollback action with "The wizard was interrupted before Cisco Backup And Restore System could be completely installed. Your system has not been modified. To complete installation at another time, please run setup again." I click finish and get a dialog box: " Cisco Backup and Restore System Install did not complete successfully, Review the log file for more information."

I have stopped the Cisco Security Agent, disabled antivirus before installing, and the web users have the logon locally privilege. The end of the BARS install log reads:

Property(C): RemoteAdminTS = 1

Property(C): MsiNTProductType = 3

Property(C): ServicePackLevelMinor = 0

Property(C): ServicePackLevel = 4

Property(C): WindowsBuild = 2195

Property(C): VersionMsi = 3.01

Property(C): VersionDatabase = 200

Property(C): CLIENTPROCESSID = 1304

Property(C): CLIENTUILEVEL = 0

Property(C): CURRENTDIRECTORY = C:\WINNT\system32

Property(C): PackagecodeChanging = 1

Property(C): ProductState = -1

Property(C): PackageCode = {ED8D4EB5-A317-4EA9-AC59-351C1F6A7103}

Property(C): CostingComplete = 1

Property(C): SourcedirProduct = {9E59E62F-54DE-4F5B-A8EC-7F3A81B33A9C}

Property(C): OutOfDiskSpace = 0

Property(C): OutOfNoRbDiskSpace = 0

Property(C): PrimaryVolumeSpaceAvailable = 0

Property(C): PrimaryVolumeSpaceRequired = 0

Property(C): PrimaryVolumeSpaceRemaining = 0

Property(C): BackAdminPrivatePwdValid = True

Property(C): BackupSrvrMatched = ""

Property(C): ServerBackAdminVerified = ""

=== Logging stopped: 6/1/2009 21:58:46 ===

MSI (c) (18:1C) [21:58:46:919]: Product: Cisco Backup And Restore System -- Installation operation failed.

06/01/2009 21:58:46.935 BARSSetup.cpp fnRunCommand CreateProcess returned: 1603

06/01/2009 21:58:46.935 BARSSetup.cpp fnRunCommand Function ended

06/01/2009 21:58:46.935 BARSSetup.cpp fnInstallPackage msiexec.exe: Error: 1603: Fatal error during installation.

06/01/2009 21:58:46.935 BARSSetup.cpp fnInstallPackage Cisco Backup And Restore System Install did not complete successfully. Review the log file for more information.

06/01/2009 21:58:51.450 BARSSetup.cpp fnInstallPackage Function ended

06/01/2009 21:58:51.450 BARSSetup.cpp WinMain Function ended.

Any help would be greatly appreciated.


Problem solved - had to logon with the local Administrator of the server to complete the installation successfully. A user belonging to the Local Administrators group did not suffice.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
gmarogi Mon, 06/08/2009 - 12:10

It looks like an issue with the new installation is due to unsuccessful/incomplete uninstallation of the older one.

So please do confirm if you have uninstalled the previous version completely. Also check if the BARS.dll is removed under C:\ and IIS.


This Discussion