Axl authentication problems

Unanswered Question
Jun 2nd, 2009
User Badges:

Hi,


I sync an ldap axl user account in ccm 7 pub and was able to log on from uccx 7.


However, I had to reinstall ccm7 pub and had to re-sync to the ldap. After that I never could not log on to uccx again.


I keep getting axl user authentication errors even though the permissions are correct.


I tried to do a test using:


http://ccm7/axl


and could not log on using the axl user created in ldap but I can log on using the call manager admin account.


The Axl service is running


Any help appreciated.


Thanks,

Paul


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
htluo Wed, 06/03/2009 - 04:40
User Badges:
  • Red, 2250 points or more

You should go to CUCM > User Management > Application User and create the AXL user account there.


On CUCM, you may create an user as "Application User" or "End User". "Application User" is always stored in the CUCM database while "End User" could be in CUCM DB or LDAP depending on your configuration.


Michael

http://htluo.blogspot.com

PAUL CHEN Thu, 06/04/2009 - 08:50
User Badges:

Hi Michael,


I found out what the problem was.


I created an user in LDAP and then I created an user group with AXL API access permissions. After that I placed the user in the group.


I kept getting Axl authentication errors when I used the user account created in LDAP.


After I removed LDAP and created a new user in CCM 7 ,it will authenticate ok.


I wonder why ? It is meant to work that way ?


By the way, if I created an user in CCM will it not remove this user when I sync call manager to the LDAP server.


How can i make sure this does not happen.


Any advice appreciated.


Thanks.

Paul

Actions

This Discussion