Paging group plays MOH

Unanswered Question
Jun 3rd, 2009

I setup a test paging group several days ago and it worked fine. Today I tried making one for real through the CCA. When I dial the paging group (101) the member phones start playing the Music on Hold (MOH), rather than the audio from the phone I called from.

I have no idea why its doing this or how to fix it.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Skyler Spence Fri, 06/05/2009 - 13:35

Hi Trevor.  This sounds like an interesting mixup indeed!  Could you post your configuration for us to review?  You can either post it here or if that makes you uncomfortable you can email it to me directly skspence at cisco.com

Brikers12 Tue, 06/16/2009 - 20:44

Sorry for the delay in response, I've not been in the office for a week. The problem is still present though, so I have attached our current config output.

Thanks for the reply!

Steven Smith Wed, 06/17/2009 - 07:46

The configuration looks correct.  Could you get a sniffer of this when this happens?  Are there any other multicast sources on the network?

Brikers12 Wed, 06/17/2009 - 21:28

Odd I added all the phones to the page group. When I initiate the 101 call from another phone it works, only the one phone plays the MOH. One of the phones I added was the wireless 7921 and it doesn't seem to work with the paging, it doens't get any incoming call when 101 is added even though its in the paging group.

When you say get a sniffer do you mean some kine of trace in the Cisco CLI? Or something on the network?

I'm not an CLI expert, i mostly find and follow instructions and try to stumble my way around. I'm not sure how I would do a trace of this action.

I'm not sure if my network has other "multicast sources"... right now all I have the the following:

UC520 (w/ wireless)

all ip-phones plugged into UC520

Catylist 500 switch

Windows Small Business Server (which acts as DHCP/DNS/gateway)

6 desktops

thanks for the response!

Steven Smith Thu, 06/18/2009 - 09:09

For the 7921, you should turn on unicast paging.  Some of the wireless devices don't work well with unicast (on the AP side)

ephone 4

paging-dn 1 unicast

By a sniffer, I mean plug into the network using a program like wireshark and capture the multicast traffic that is going on at the time.

jwaters24 Wed, 07/15/2009 - 13:45

I am having the same issue.  I configured in the CCA 2.0 tool, 1 paging group and added 16 of the 18 phones to it.  None of the phone are wireless.  When I dial the paging extension, the MoH comes through the phones along with the page.

Please advise.

Marcos Hernandez Thu, 07/16/2009 - 06:20

Nice! Two for one!

Seriously, this is probably due to the fact that the paging IP and MOH IP are the same. Can you please post a copy of your configuration? If this was all done via CCA, then you might have found a bug.

Thanks,


Marcos

Marcos Hernandez Thu, 07/16/2009 - 11:24

The IP's are different, which means this is starting to smell like a bug. Could you try to remove this command from under "telephony -service" :  multicast moh 239.10.16.16 port 2000. Test again and let me know.


Thanks,


Marcos

jwaters24 Thu, 07/16/2009 - 11:34

ok.  so I did that command. It indeed to away the MoH while paging and the paging worked.  The MoH feature does not work when I place a call on hold.

any suggestions.

Marcos Hernandez Thu, 07/16/2009 - 11:38

Unicast MoH should have kicked in. Can you please open a TAC case? This is one of those that we will need to debug further.

Thanks,


Marcos

Marcus,

Was this issue resolved (back in July of 2009)?

I'm having this same issue with a phone system that I just upgraded to the latest software pack (8.0.0).  The issue did not present itself until after the software pack upgrade.  After looking at the config, I noticed moh uses the same port as the paging group:

telephony-service
......

moh flash:/media/music-on-hold.au
multicast moh 239.10.16.16 port 2000

!

ephone-dn  1
number 1111 no-reg primary
description All Phones
name IP-Paging1
paging ip 239.1.1.1 port 2000

!

Is this normal or should I change the port on one of these?

Marcos Hernandez Fri, 12/18/2009 - 12:52

Don't change anything for now. Let me recreate this problem and I will get back to you ASAP.


Marcos

Steven DiStefano Wed, 12/30/2009 - 07:28

Hi,

I just tried this and Paging worked fine on a UC 520 running 8.0 bundle zip.

I configured it with CCA 2.2.1

The resulting config is here:

ephone-dn 1
number 101 no-reg primary
name IP-Paging1
description All
preference 0 secondary 9
huntstop
call-waiting beep
paging ip 239.1.1.1 port 2000
no cti notify
no cti watch

ephone-dn 9
number BCD no-reg primary
description MoH
preference 0 secondary 9
huntstop
call-waiting beep
moh mode
moh out-call ABC
no cti notify
no cti watch

I am not sure what marcos was checking and if he was able to recreate your scenario, but we can wait till Cisco reopens after New years day to find out.

In the mean time, I checked it for you and dont have a generic problem.  You can call TAC if you have an issue that is causing you grief at the current time.

Steve DiStefano

Systems Engineer

US Field Channel Sales team

Actions

This Discussion

Related Content