Voicemail notification flashing, but no new voicemail

Answered Question
Jun 3rd, 2009

I have a SPA525G IP phone that I was testing voicemail with. I left a message on that phones extension, listened to it, then deleted it. But the flashing icon beside the extension number on the LCD won't go away. The Message Waiting Indicator also always remains red.

There are no new or saved voicemails anywhere on the system currently.

I checked and the 2 A800 & A801 "Message Waiting Indication (MWI)" are present. But just in case I deleted them using the CCE and then re-created them. I also tried the "Message Waiting Indicators > Refresh", but the flashing icon is still there.

I have setup voicemail IMAP up in Outlook for this user, its working, when I left the test voicemail, the email was sent.

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Marcos Hernandez Wed, 06/03/2009 - 05:01

Does this happen to other phone models (if you have any other)? What happens if you reboot the SPA525G?


Brikers12 Thu, 06/04/2009 - 19:25

thanks for the replies!

If I reboot the SPA525G nothing changes, the red like and blinking icon are still there. I do have some 524SG phones, they have no red light or blinking icon. However they have never recieved a voicemail. I just called one of these 524 phones and left a message, there is no indication on the phone that there is a waiting voicemail.

I mentioned in my first post that I tried the "Refresh" through the CCE interface. I just tried again, no change.

This may sound really dumb.. but how do I call the MWI numbers to test them? They are A800 & A801. Would I dial 2800? I tried dailing that and just plain 800, neither work.

What is the proper setting for "E.164 Registration" on the MWI extenstion? When I deleted and re-created them I wrote down the previous settings first and it was set to "Primary no Reg".

here are the extensions from my config. I also attached my entire config output.

ephone-dn  55
number A801 no-reg primary
mwi off
ephone-dn  56
number A800 no-reg primary
mwi on

I also wanted to mention I logged in with Voiceview on the SPA525G to make sure there was no new messages, there is none. I also logged into the 524 phone I just left a message on, its visible in Voiceview.

Brikers12 Thu, 06/04/2009 - 20:43

A small update, I setup a Speed dial line key from the thread here https://www.myciscocommunity.com/thread/3068?tstart=0

I had to restart the phone for the changes to apply, when the phone restarted the MWI notification lights and such are all off now. But the problem is not fixed, I tried leaving a new voicemail and the phone is not indicating there is a new message. I tried another MWI Refresh, nothing changed.

I then deleted my Speed dial and restart the phone again, after restarting the MWI was flashing again. So I dailed 299 and deleted the message i left before, but as i suspected the MWI didn't turn off.

So it seems it can get a MWI update only if the phone is restarted...

Brikers12 Wed, 06/17/2009 - 03:08

thanks for the reply. I'm unable to access the TAC tool at this moment, I'm trying to get that resolved with my partner and Cisco.

But here is some more info in-case someone out there might see the solution.

The "Voicemail Status" in CCA correctly lists when there is a new message, so its updating fine. I also checked the "SIP gateway hostname" in CCE, it seems to all be correct. I attached screenshots of both.

I also tried a "debug ccsip messages" while making a call to a phone and leaving a message, I'm not sure if that is helpful (log also attached).

Brikers12 Wed, 06/17/2009 - 04:16

I thought that the "A" in the MWI extensions could be a problem, so to rule it out I changed the numbers to 800 & 801. To make sure CUE was also updated I executted the following in the CLI.

ccn application ciscomwiapplication aa
description "ciscomwiapplication"
maxsessions 6
script "setmwi.aef"
parameter "CallControlGroupID" "0"
parameter "strMWI_OFF_DN" "801"
parameter "strMWI_ON_DN" "800"

end application

The "other status" in CCA shows the above changes (see screenshot: mwiapp.PNG).

Now in the CME when I try and run the "Administration > Synchronize Information", I get the following for both the A800 and 800.

The following configuration on the CME and CUE  is unsynchronized -
Synchronize MWI On number
800 is not a valid MWI On number on CME.  Create a new MWI On number on CME.
Synchronize MWI Off number
801 is not a valid MWI Off number on CME.  Create a new MWI Off number on CME.

Now back over in the CCME, the 800 & 801 extensions are present, but when looking at the "Message Waiting Server Settin" I'm wondering if the settings here are correct... (see screenshot: ccme_voice.PNG).

Also in the CUE "Message Waiting Indicators > Settings" it says "No MWI on Numbers Defined on CCM" (see screenshot: outcalling.PNG")

Brikers12 Wed, 06/17/2009 - 04:35

OH YES!!! I just got it working!

It seems adding 3 dots to the end of the extenstion number was the trick. I deleted the ephone-dn's in the CLI and re-created them with dots as follows:

ephone-dn  55
number 800... no-reg primary
mwi on

ephone-dn  56
number 801... no-reg primary
mwi off

Then in CUE i was able to "Synchronize Information" with no errors and now the 800 & 801 are listed under "Outcalling".

I tested leaving voicemail and deleting voicemail, the MWI indicator worked perfectly!

Steven DiStefano Wed, 06/03/2009 - 05:52

Good morning Trevor,

I was curious if the MWI refresh helps.

If you launch a web browset at and log in as cisco/cisco and navigate to VOice Mail -->  MWI Indicators --> Refresh, Select the SPA525G and "Refresh Setting", does that help?


jmaudlin Thu, 06/04/2009 - 06:07

Also try dialing the MWI numbers to make sure there is not an issue there.