Cat 3560 voice vlan problem

Unanswered Question
Jun 3rd, 2009


I have some problem with Cat 3560 running c3560-ipbase-mz.122-35.SE1. When we configure voice vlan on the access port, and the access port is connected to PCs, we encounter packet 50% drop. The reason we configure voice vlan at this stage is to facilitate IPT deployment for next month.

Once i remove the voice vlan command, everything is back to normal.

Has anyone encounter this problem before? I search the release notes and couldn't find anything on it.


Eng Wee

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mahmoodmkl Wed, 06/03/2009 - 04:44


Can u paste the current config of the port.

r u not defining any access vlan on the port..?.



e-chuah Wed, 06/03/2009 - 04:48

Hi Mahmood,

Yes, there is a switchport access vlan in that port. Sample config of the port

int fa0/0


switchport access vlan 10

switchport voice vlan 20

switchport host

mahmoodmkl Wed, 06/03/2009 - 04:52


can u add the below line and check

switchport mode access



e-chuah Wed, 06/03/2009 - 19:23


The command is already there. But still same problem.


Leo Laohoo Wed, 06/03/2009 - 21:52

Hi Eng Wee,

Have you tried other switch? Do you see any line errors? What is the duplex and speed setting? What is the make/model of the phone?

e-chuah Wed, 06/03/2009 - 21:59


It's the same with other switches.

Duplex and speed setting is auto.

It is not the phone that is connected to the switch, we are connecting PC's directly to the access port which has "voice vlan" configured. There is no interface error in the access port interface.

I am suspecting some compatibility issue with some NIC...


ayeoman Thu, 06/04/2009 - 00:11


I have used the 3560 for voice and data.

My configs look something like this:

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

switchport voice vlan 20

srr-queue bandwidth share 1 70 20 10

priority-queue out

mls qos trust dscp

spanning-tree portfast trunk

The SRR and QOS bits are optional but may help with voice quality in future.


frankie_sky Wed, 06/03/2009 - 22:37

Maybe you apply below command to the switchport.

"spanning-tree portfast"


This Discussion