EIGRP update problem on FRover PPP

Unanswered Question
Jun 3rd, 2009

Hi, I am facing one strange problem with PPP over FR. I have router R1 & R3 connected over FR. I have configured PPP over FR on Vitual Templete. I am using EIGRP. The problem is EIGRP neighbor is formed, but they are not exchanging the routing table. I have attached three configuration file. Please help. If I configured OSPF or RIP, I am getting the updates. Only problem is with EIGRP.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Wed, 06/03/2009 - 10:43

Hello Rupesh,

first of all this is PPP over FR and not the opposite.

note2:

clearly no hello packet is received on the virtual-access.

What if you add neighbor commands under router eigrp so that you don't use multicast destination by unicast.

Can you ping on the virtual-template the other side (167.1.135.3 from R1 and 167.1.135.1 from R3)?

Have you got a FR switch in the middle to convert DLCI 301 to 103 and viceversa ?

Hope to help

Giuseppe

Rupesh Kashyap Wed, 06/03/2009 - 10:52

Hi, I am able to ping. Fr is configured for vice-versa traffic. I tried with Neighor too, but not working. If I change the protocol like ospf or rip, I am getting the updates.

As u mentioned, hello is not received. I debug the traffic and found hello traffic. So summary, there is no problem in basic functionality of Eigrp. If I remove PPP over FR/Virtual templete, I am getting the eigrp updates.

Edison Ortiz Wed, 06/03/2009 - 11:26

Rupesh,

I'm not sure what the problem is. I copied and paste your configuration (verbatim) into my dynamips and it worked right out of the box.

R1#sh frame pvc | i Virtual|ACTIVE

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

Bound to Virtual-Access1 (up, cloned from Virtual-Template1)

R3#sh frame pvc | i Virtual|ACTIVE

DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

Bound to Virtual-Access1 (up, cloned from Virtual-Template1)

R1#sh ip eigrp ne

IP-EIGRP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 167.1.135.3 Vi1 13 00:02:34 274 1644 0 4

R3#sh ip eigrp ne

IP-EIGRP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 167.1.135.1 Vi1 10 00:02:46 192 1152 0 3

R1#sh ip route e

150.1.0.0/24 is subnetted, 2 subnets

D 150.1.3.0 [90/2713600] via 167.1.135.3, 00:03:02, Virtual-Access1

R3#sh ip route e

150.1.0.0/24 is subnetted, 2 subnets

D 150.1.1.0 [90/2713600] via 167.1.135.1, 00:02:58, Virtual-Access1

HTH,

__

Edison.

Rupesh Kashyap Wed, 06/03/2009 - 23:29

yes, it was ios bug. I have changed the IOS and now it is working. Thanks both of you for the prompt reply and efforts.

Actions

This Discussion