NetConfig Error

Unanswered Question
Jun 4th, 2009

When running NetConfig jobs I get a high rate of failure with the error "ERROR:RME_CDL1031:Transport session to device failed TFTP: Failed on the device. Could not detect SSH protocols running on the device"

I've checked the DCR an everything seems fine. When I do a "Management Station to Device" check Telnet & SNMP work fine but TFTP fails. However, even for the devices that were successful during the NetConfig job TFTP still fails.

Any help please?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Thu, 06/04/2009 - 14:13

This error means that either the SNMP read-write community string is wrong, the device cannot issue a TFTP read request back to the RME server, and SSH is not available on the device. It looks like those are the only two protocols you selected, so you will need to fix one of those problems. A sniffer trace of all traffic to the device should help illustrate the exact nature of each problem.

BlueyVIII Thu, 06/04/2009 - 14:38

The "Management Station To Device" check for a failed devices says that Telnet and SNMP are OK. Does this check include the SNMP read/write community or just the RO?

SSH isn't configured on the devices (no crypto image) so I wouldn't expect this to work.

The other devices that are working have almost exactly the same config (only IP Address and VLAN changes) and the same IOS version?

Joe Clarke Thu, 06/04/2009 - 14:42

The checks do test everything. Since it sounds like TFTP is your only working choice, you really should get the sniffer trace to see where the failure is occurring. You'll want to filter on all UDP traffic between the server and device.

BlueyVIII Fri, 06/05/2009 - 06:23

Thanks. I got a sniffer sessions ready and setup exactly the same netconfig job for one the switches that had failed last time.

When the netconfig job ran this time it worked fine on the device that had previously failed.

I tried another device that had failed last time and this also worked!!

Could it be that the TFTP server is faliing to handle mutliple devices when the job us running for hundreds of devices in parallel mode? I think I read that RME runs 5 at a time in parallel mode but could the TFTP server need configuring to match this?

After more tests I've learned that jobs with 5 or less devices work fine, jobs with more than 5 devices will experience failures.

Would a workaround be to run the job in sequential mode? (although it may take several hours to run the job??)

Joe Clarke Fri, 06/05/2009 - 09:16

There is nothing in RME that would explain this. In fact, RME will only fetch at most five devices in parallel. It almost sounds like something in the network is throttling UDP.

If you can reliably reproduce this for six devices, start a sniffer trace filtering on UDP traffic to all six devices. Perform the job, then check the trace for the device that failed.

BlueyVIII Fri, 06/05/2009 - 09:26

OK, will give this a try..

Not sure I'll be able to recreate with just 6 devices. My previous post was worded badly, there's no problem with a job that contains five or less devices. Other tests that have failed have been using around 30 devices, I've tried nothing in between 5 and 30 so am not sure at what point if fails.

I'll also try in sequential mode and see how that works.


This Discussion