Personal communicator via VPN with oneway voice ?

Unanswered Question
Jun 5th, 2009

We are using personal communicator in our organization for end users desktop & Laptops! When they dial outside (any mobile) number from personal communicator, then the mobile ring and two way communication established, but when the same users use their laptop from home via VPN and use the personal communicator, when they dial out side mobile numbers, only one way communication is established. On the same laptop if they use (IP communicator) then no issue, they dial out side mobile,land line and two way communication gets established. I know that IP Communicator uses SCCP & Personal Communicator uses SIP to get registered with the Call Manager 6.1.

Any help regarding the above issue would be really appreciated


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Dennis Mink Fri, 06/05/2009 - 05:00

you need to do some more diganostics.

If you call to the VPN CUPC client, does it ring (in other words does SIP signalling get through to CUPC?) What about the other way around?; if you dial a number from CUPC does it ring the other party's phone?

sounds like a signaling issue, your RTP streams go through your ASA OK, the SCCP IP communicator proves this.

Is there any NAT between CUPC on the VPN client and your CUCM? NAT can bugger up SIP big time by not re-writing the SIP headers. Focus on that first

chadlincoln Fri, 06/05/2009 - 06:15

The ACL's on your VPN access lists do not allow the subnet the VPN users to route to the subnet the gateway is on. You say there is one way audio. Which side can hear who? Again, it's a routing/VPN ACL issue.

Please rate if this helps.

parshah Fri, 06/05/2009 - 09:45


What is the version of CUPC you are using. There were issues with CUPC over VPN on some of the older versions.

If you are on the latest and still have the same issue, its probably an ACL issue, where SIP msg between CUPC and CUCM are not being exchagned properly.

Can you check 2 things

1. When CUPC is registered as softphone over VPN, what is the IP of that device in CUCM. It should be the same as the users IP unless you are doing NAT. If you are doing NAT than it might be the problem.

2. Get a sniffer from the user's PC when he/she initiates a call and one-way audio is recreated. In the sniffer, look at the SIP msg exchanged between CUPC and CUCM. Pay special attention to the SDP in the SIP msg and verify that the source and destination IP address for RTP are correct.

3. One last question, what happens when CUPC over VPN calls an internal number or another CUPC over VPN user? Do you get 2-way audio?

wahidayat007 Mon, 06/08/2009 - 04:36

Thanks for your comments!

well Today I tried again to use CUPC over vpn, and it worked, CUPC established call to the outside mobile, but the conversation was not very good, thought it was two way conversation, but after 50 sec's elapsed, the call got disconnected! I tried again to a different number then again call gone upto 45 sec, and dropped. Call shows on CUPC connected, but the remote party (mobile) phone shows call terminated!

I have done the sniffer thingy! I captured the packets!

8634 172.882187 RTCP Source description


8635 172.886599 RTP PT=ITU-T G.711 PCMU, SSRC=0x258FF06, Seq=9769, Time=3423424678


8636 172.886647 ICMP Destination unreachable (Port unreachable)


8645 172.972771 ICMP Destination unreachable (Port unreachable)


Yes, when I make internet call over VPN no issue!


This Discussion