command “clear ip nat translation *” restarts my 2811 router

Unanswered Question

Hi,


Why router getting restarted while clearing ip nat translations?

i am using 2811 router connected to two internet link.

details

IMEDIAROUTER1#sh ver

Cisco IOS Software, 2800 Software (C2800NM-IPBASE-M), Version 12.4(15)T7, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Wed 13-Aug-08 17:09 by prod_rel_team


ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)


IMEDIAROUTER1 uptime is 1 day, 4 hours, 20 minutes

System returned to ROM by error - a Software forced crash, PC 0x40081F1C at 09:13:09 PCTime Fri Jun 5 2009

System image file is "flash:c2800nm-ipbase-mz.124-15.T7.bin"


Cisco 2811 (revision 53.50) with 249856K/12288K bytes of memory.

Processor board ID FCZ131770WA

3 FastEthernet interfaces

DRAM configuration is 64 bits wide with parity enabled.

239K bytes of non-volatile configuration memory.

62720K bytes of ATA CompactFlash (Read/Write)


Configuration register is 0x2102

--------

interface FastEthernet0/0

description $LAN$

ip address 10.10.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip policy route-map PBR

duplex auto

speed auto

!

interface FastEthernet0/1

description $WAN1$

ip address 3.3.3.4 255.255.255.252

ip nat outside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

!

interface FastEthernet0/0/0

description $WAN2$

ip address 2.2.2.3 255.255.255.252

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0/0

ip route 10.10.0.0 255.255.0.0 10.10.1.2

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source static tcp 10.10.11.11 21 interface FastEthernet0/1 21

ip nat inside source static tcp 10.10.11.11 20 interface FastEthernet0/1 20

ip nat inside source static tcp 10.10.11.17 1433 interface FastEthernet0/1 1433

ip nat inside source static tcp 10.10.11.1 80 interface FastEthernet0/0/0 80

ip nat inside source route-map 1RB_NAT interface FastEthernet0/0/0 overload

ip nat inside source route-map ALL_USER_NAT interface FastEthernet0/1 overload

!

ip access-list extended ALL_USERS

deny ip host 10.10.11.1 any

permit ip 10.10.0.0 0.0.255.255 any

ip access-list extended RB_SERVER

permit ip host 10.10.11.1 any

deny ip any any

!

logging trap debugging

route-map ALL_USER_NAT permit 20

match ip address ALL_USERS

match interface FastEthernet0/1

!

route-map 1RB_NAT permit 10

match ip address RB_SERVER

match interface FastEthernet0/0/0

!

route-map PBR permit 10

match ip address RB_SERVER

set ip next-hop 2.2.2.2

set interface FastEthernet0/0/0

!

route-map PBR permit 20

match ip address ALL_USERS

set ip next-hop 3.3.3.3

set interface FastEthernet0/1

!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Sat, 06/06/2009 - 02:15

Have a look at the following bug report. It talks about it being on 7200/7300 routers but it could well be relevant to your case as well. Note that the bug was found in the version of code you are running so i would recommend upgrading code to see if that fixes your problem -


http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCso19662&from=summary


Jon

Actions

This Discussion