mpls global route leaking

Unanswered Question
Jun 6th, 2009

Please find attached visio diagram ,

i want to leak a global route from router R4 to VRF between R3 and R5

R3 is in VRF and running rip with PE1R2,

Connectivity from R3 to R5 through vpn is fix no issues now i want to leak a global route (a loopback interface)from R4 to VRF in which R3 and R5 are.

the protocol in between PE and P and PE is OSPF.

What i shld configure.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Harold Ritter Sat, 06/06/2009 - 17:12

Adam,

You can simply configure a VRF static route on PE1R2 and then redistribute static for the appropriate VRF context under the BGP process.

ip router vrf xyz 255.255.255.255 global

router bgp xxx

address-family ipv4 vrf xyz

redistribute static

Don't forget that if you want to have IP connectivity between R4 and let's say R3, you will also need to inject a route to R3 subnet(s) into the global routing table on PE1R2. You will need to specify the physical interface on the static route command as follow:

ip route

router ospf xxx

redistibute static subnet

Regards

adamgibs7 Sun, 06/07/2009 - 02:09

Hritter,

very good explanation,appreciate.

Hritter Now i can reach R4 loopback from R3 the route is present in vrf,but am not able to ping R3 subnet from R4 or PE1R2.The subnet between PE1R2 and R3 is 192.168.23.0 when i specify a staic route and redistribute it appears in routing table as such but it doesnt ping its own interface F1/0 on PE1R2 (192.168.23.2) which is assigned to vrf for R3.

PE1R2#sh ip route

Gateway of last resort is not set

C 192.168.24.0/24 is directly connected, FastEthernet2/0

O 192.168.9.0/24 [110/2] via 192.168.20.1, 00:25:55, FastEthernet0/0

O 192.168.10.0/24 [110/2] via 192.168.20.1, 00:25:55, FastEthernet0/0

192.168.4.0/32 is subnetted, 1 subnets

O 192.168.4.4 [110/2] via 192.168.24.4, 00:25:55, FastEthernet2/0

C 192.168.20.0/24 is directly connected, FastEthernet0/0

S 192.168.23.0/24 is directly connected, FastEthernet1/0

O 192.168.1.0/24 [110/3] via 192.168.20.1, 00:25:55, FastEthernet0/0

C 192.168.2.0/24 is directly connected, Loopback0.

192.168.23.0

f1/0

R3-----------PE1------P-PE2--R5

.3 .2 | f2/0

| .2

| 192.168.24.0

| .4

R4

Thanks

Harold Ritter Sun, 06/07/2009 - 07:59

Adam,

It is normal behavior for PE1R2 not to be able to ping R3 via the global as it should use the VRF to do so. Try pinging 192.168.23.2 from R4 using the loopback address as the source IP address. This should work, assuming that the route for the loopback address is correctly configured in the VRF.

Regards

adamgibs7 Sun, 06/07/2009 - 11:34

Hi Hritter,

Do click this for me i have done that,sometimes i dou't the GNS3 acting funny for me and spoiling my knowledge,pasting the sh ip route for R4

R4#sh ip route

Gateway of last resort is not set

C 192.168.24.0/24 is directly connected, FastEthernet1/0

C 192.168.4.0/24 is directly connected, Loopback1

O 192.168.20.0/24 [110/2] via 192.168.24.2, 00:00:15, FastEthernet1/0

O E2 192.168.23.0/24 [110/20] via 192.168.24.2, 00:00:15, FastEthernet1/0

O 192.168.2.0/24 [110/2] via 192.168.24.2, 00:00:15, FastEthernet1/0

As u can c the route:

O E2 192.168.23.0/24 [110/20] via 192.168.24.2, 00:00:15, FastEthernet1/0

am able to ping from the source address successfully but now i dont have a route in R3 for loopback it is present in R2,R1,R5 in VRF but not in R3 nd am not able to ping from R1 and R5,in morning route was present for R3 and successfully pinging but now when i started the GNS3 with saved config's the route disappear,

It should also ping from R1 and R5??? If am not wrong,the route is present but it is not pinging from R1 and R5.

All the way thanks for ur help,Awaiting for ur last reply

My CPU is reaching 100% and memmory is been over utilized by GNS3.

Thanks

Harold Ritter Sun, 06/07/2009 - 15:02

Adam,

You also need to make sure you redistribute the static VRF route (for R4 loopback address) into RIP so R3 receives it.

Regards

Harold Ritter Sun, 06/07/2009 - 15:06

Adam,

You should also be able to ping R4 loopback address from R5 assuming the route to R5 source address has been installed and redistributed into the global as well.

Regards

adamgibs7 Mon, 06/08/2009 - 10:34

Hello Hritter,

I have redistributed the static VRF route in RIP and BGP but still R3 is not able to ping,I have done this today morning on physical switches still R3 is not able to ping,R3 is having route for loopback but still it is not pinging,

From R4 it is pinging the R2 VRF interface and vice versa but packets are getting drop 3/5. What could be the possible reason.

Just have a look on R2 configs,

version 12.4

no service timestamps debug uptime

no service timestamps log uptime

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

!

!

ip vrf test

rd 100:20

route-target export 100:20

route-target import 100:20

!

!

interface Loopback0

ip address 192.168.2.2 255.255.255.0

ip ospf network point-to-point

!

interface FastEthernet0/0

ip address 192.168.20.2 255.255.255.0

duplex auto

speed auto

mpls ip

!

interface FastEthernet1/0

ip vrf forwarding test

ip address 192.168.23.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 192.168.24.2 255.255.255.0

duplex auto

speed auto

!

interface Serial3/0

no ip address

serial restart-delay 0

!

interface Serial3/1

no ip address

serial restart-delay 0

!

interface Serial3/2

no ip address

serial restart-delay 0

!

interface Serial3/3

no ip address

serial restart-delay 0

!

router ospf 1

router-id 192.168.2.2

log-adjacency-changes

redistribute static subnets

network 192.168.2.2 0.0.0.0 area 0

network 192.168.20.2 0.0.0.0 area 0

network 192.168.24.2 0.0.0.0 area 0

!

router rip

version 2

no auto-summary

!

address-family ipv4 vrf test

redistribute bgp 100 metric transparent

redistribut static metric transparent

network 192.168.23.0

no auto-summary

version 2

exit-address-family

!

router bgp 100

bgp router-id 192.168.2.2

bgp log-neighbor-changes

neighbor 192.168.1.1 remote-as 100

neighbor 192.168.1.1 update-source Loopback0

!

address-family ipv4

neighbor 192.168.1.1 activate

neighbor 192.168.1.1 next-hop-self

no auto-summary

no synchronization

exit-address-family

!

address-family vpnv4

neighbor 192.168.1.1 activate

neighbor 192.168.1.1 send-community extended

neighbor 192.168.1.1 next-hop-self

exit-address-family

!

address-family ipv4 vrf test

redistribute static

redistribute rip

no synchronization

exit-address-family

!

no ip http server

no ip forward-protocol nd

ip route 192.168.23.0 255.255.255.0 FastEthernet1/0

ip route vrf test 192.168.4.4 255.255.255.255 192.168.4.4 global

!

!

route-map static permit 10

match interface FastEthernet1/0

!

!

mpls ldp router-id Loopback0

!

control-plane

!

line con 0

line aux 0

line vty 0 4

no login

!

end

Harold Ritter Mon, 06/08/2009 - 16:55

Adam,

- Does R3 have a route to R4 loopback address?

- Does R4 have a routes back to R3 source address?

If so, it should work as the configuration of PE1R2 looks good.

Regards

Actions

This Discussion