Can't connect to Console after trying to xfer new IOS...???

Unanswered Question
Jun 7th, 2009
User Badges:

Hey whats up... So I've done some googling and a forum search here and nothing to help me came up.


[b]So my problem is this:[/b] I have a 2811 router and there's no IOS on flash. I go into Rommon> mode and started to follow a cisco tutorial to xfer an IOS from my pc..(CCNA Portable Command Guide book). After i disconnected to change the baude rate of my connection (Using Putty) i realized that putty didnt have an option for trasfer. So i open HyperTerm and try to send the file using 115200 8-N-1 no flowcontrol, nothing happens. Now no matter what settings my hyperterm is using i cant connect to the router to get into rommon> mode.


Any advice??????

Thnx


****Listed below is a cleaned up log from when i was doing this:


[b]rommon 2 > confreg[/b]

Configuration Summary (Virtual Configuration Register: 0x2102)

enabled are:


load rom after netboot fails

console baud: 9600

boot: image specified by the boot system commands

or default to: cisco2-c2811

do you wish to change the configuration? y/n [n]:[b]y[/b]

enable "diagnostic mode"? y/n [n]: [b]n[/b]


enable "use net in IP bcast address"? y/n [n]: [b]n[/b]

disable "load rom after netboot fails"? y/n [n]: [b]n[/b]

enable "use all zero broadcast"? y/n [n]: [b]n[/b]


enable "break/abort has effect"? y/n [n]: [b]n[/b]

enable "ignore system config info"? y/n [n]: [b]n[/b]

change console baud rate? y/n [n]: [b]y[/b]

enter rate: 0 = 9600, 1 = 4800, 2 = 1200, 3 = 2400

4 = 19200, 5 = 38400, 6 = 57600, 7 = 115200 [0]: [b]7[/b]

change the boot characteristics? y/n [n]: [b]n[/b]


Configuration Summary (Virtual Configuration Register: 0x3922)

enabled are:


load rom after netboot fails

console baud: 115200

boot: image specified by the boot system commands or default to: cisco2-c2811

do you wish to change the configuration? y/n [n]: [b]n[/b]


You must reset or power cycle for new config to take effect

[b]rommon 3 > reset[/b]

Ðàôg| [”GÜç Èø

[b]rommon 1 > xmodem [/b]

[b]rommon 1 > xmodem c2800nm-advipservicesk9-mz.124-22.YB2.bin[/b]

Do not start the sending program yet... File size Checksum File name

WARNING: All existing data in flash will be lost!

Invoke this application only for disaster recovery.

Do you wish to continue? y/n [n]: [b]y[/b]

Ready to receive file c2800nm-advipservicesk9-mz.124-22.YB2.bin ...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dario.didio Mon, 06/08/2009 - 01:18
User Badges:
  • Silver, 250 points or more

Did you then select in hyperterminal

Transfer -> send File... -> Filename: your file and Protocol: XModem ?


Because your router is ready to receive it: Ready to receive file c2800nm-advipservicesk9-mz.124-22.YB2.bin ...

ImThatGuy83 Mon, 06/08/2009 - 01:29
User Badges:

Yes, Thats exactly what I did. And then HyperTerm gave me an error that it couldn't connect.


I've tried every HyperTerm settings to connect and nothing seems to be working for me.


MK

Giuseppe Larosa Mon, 06/08/2009 - 05:18
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Michael,

have you closed the putty application ?

hyperterm can find the pc port busy.


Hope to help

Giuseppe


ImThatGuy83 Mon, 06/08/2009 - 05:32
User Badges:

Yes, I closed Putty. After I saw the router tell me it was ready to recieve the IOS, I tried to find a transfer option in Putty and couldn't see one. Knowing HyperTerm has one, I tried to connect with that and haven't been able to connect since that point.


I know that there must be something I'm missing.


After alot of failed attempts to connect to the router. I power cycled the device, that would mean its not trying to accept a IOS anymore but shouldn't i still be able to get a connection and get into Rommon> mode even at 115200 baud rate?


MK

ImThatGuy83 Mon, 06/08/2009 - 05:37
User Badges:

Yes, I did exactly as you listed several times with no luck. It would give me a generic unable to connect error.


I've tried zmodem, ymodem and all that knowing it wouldn't work but figured it was worth a shot. haha


I've tried every possible config combo of 9600 & 115200, using 8-N-1 with no flow control, using both my com1 and com2. And nothing.


I know that typically in these types of situations, it would be a simple wrong setting somewhere.


I've even went into device manager, to change the setting of the Com ports in there as well.


Im completely stuck..


Thnx for the replies everyone...


MK

dario.didio Mon, 06/08/2009 - 05:58
User Badges:
  • Silver, 250 points or more

Hi,


At this point, can you connect via console to your router and get a prompt?


If no, let's forget putty for a moment and continue with hyperterminal.

configure your serial connection the way you've set it in your router:


default:

Bits per second: 9600

data bits: 8

Parity: None

Stop bits: 1

Flow control: hardware


You've changed only the bits per sencond, so put 115200.


If this is working, you gaint back control over your router.


follow this procedure:

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bfac.shtml


Make sure no other program is using your COM1 port (assuming you are using COM1)


You are sure that there are no memory problems to support the new IOS? Hardware and software are compatible. There is enough space on your flash?


Keep us posted about the progress!


HTH,

Dario

ImThatGuy83 Mon, 06/08/2009 - 11:03
User Badges:

At this point I have no connection to the router to get back to a Rommon> mode prompt.


Thanks for the link, I have actually refrenced that guide when I started this process.


You list Flow Control: Hardware

I think I read somewhere that it should be none. Any definitative anwser on that?


The router is a 2811, with 64MB of flash. This IOS is for 2800 series routers and is an advanced ip ios, but it should be good for the flash. It was downloaded by a classmate for me from Cisco.com.


I'll update once I get home from work and get another chance to work on it.


Thnx

Actions

This Discussion