VG224 Fax Passthrough not recognizing digits dialed

Unanswered Question
Jun 8th, 2009

We are switching from fax relay to fax passthrough on our VG224 fax gateway, however once I make the switch the VG224 stops recognizing dialed digits. When I try to dial a number from a fax machine I get the dial tone and hear the tones for the digits dialed, but after about 5 seconds I get another dial tone and then the call times out. Any thoughts?


This is connected via MGCP to our Callmanager 7 cluster.


I also after making this change cannot receive any inbound calls (just get a busy signal) If I run a debug voip ccapi inout on the VG224 I get the following:


VG224-1#

Jun 8 22:32:06.894: //-1/xxxxxxxxxxxx/CCAPI/ccIFCallSetupRequestPrivate:

Interface=0x630D561C, Interface Type=6, Destination=, Mode=0x9,

Call Params(Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

Called Number=(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,

Subsriber Type Str=, FinalDestinationFlag=FALSE, Outgoing Dial-peer=0, Call Count On=FALSE,

Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)

Jun 8 22:32:06.894: //86/082A60268091/CCAPI/ccIFCallSetupRequestPrivate:

SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1

Jun 8 22:32:06.894: //86/082A60268091/CCAPI/ccCallSetContext:

Context=0x633EF9A0

Jun 8 22:32:06.898: //86/082A60268091/CCAPI/cc_api_call_proceeding:

Interface=0x630D561C, Progress Indication=NULL(0)

Jun 8 22:32:06.898: //86/082A60268091/CCAPI/ccCallModify:

Nominator=0x4000000, Params=0x633373A0, Call Id=86

Jun 8 22:32:06.902: //86/082A60268091/CCAPI/ccCallFeature:

Feature Type=23, Call Id=86

Jun 8 22:32:06.902: //86/082A60268091/CCAPI/cc_api_call_modify_done:

Result=0, Interface=0x630D561C, Call Id=86

Jun 8 22:32:06.902: //86/082A60268091/CCAPI/cc_api_call_alert:

Interface=0x630D561C, Progress Indication=INBAND(8), Signal Indication=SIGNAL RINGBACK(1)

Jun 8 22:32:06.906: //86/082A60268091/CCAPI/cc_api_call_alert:

Call Entry(Retry Count=0, Responsed=TRUE)

Jun 8 22:32:06.906: //86/082A60268091/CCAPI/ccCallFeature:

Feature Type=33, Call Id=86

Jun 8 22:32:06.906: //86/082A60268091/CCAPI/ccGenerateToneInfo:

Stop Tone On Digit=FALSE, Tone=Null,

Tone Direction=Network, Params=0x0, Call Id=86

Jun 8 22:32:06.906: //86/082A60268091/CCAPI/ccCallDisconnect:

Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Jun 8 22:32:06.906: //86/082A60268091/CCAPI/ccCallDisconnect:

Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)

Jun 8 22:32:06.906: //86/082A60268091/CCAPI/cc_api_get_transfer_info:

Transfer Number Is Null

Jun 8 22:32:06.914: //86/082A60268091/CCAPI/cc_api_call_disconnect_done:

Disposition=0, Interface=0x630D561C, Tag=0x0, Call Id=86,

Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)

Jun 8 22:32:06.914: //86/082A60268091/CCAPI/cc_api_call_disconnect_done:

Call Disconnect Event Sent

VG224-1#

VG224-1#



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Mon, 06/08/2009 - 17:25

I can't tell what the problem is from the debugs/description.


If you can post 'show run' and then:

debug voip ccapi inout

debug mgcp packet



I can probably tell you what's going on.


My best guess is this:

You aren't matching the right incoming dial peer. 'debug voip dial-peer' and your incoming dial peer should have the port and 'service mgcpapp' on it.

Or, you just don't have the dial peer with service mgcp app on it.


Make sure that 'show mgcp endpoint' shows the port you're working with.



-nick

NPT_2 Mon, 06/08/2009 - 18:11

I'll see about posting the config and debugs when I can.


My first thought was the dial peer's were not being matched, but I can make calls if I use T.38 fax relay, but if I switch to fax passthrough (without making any other changes) I lose the digit recognition.


I'm switching from relay to passthrough to avoid some compatibility issues I have been running into with certain fax machines.

NPT_2 Tue, 06/09/2009 - 07:32

Here is the VG224 Configuration, let me know if you see anything out of the ordinary.


VG224-1#show run

Building configuration...


Current configuration : 3198 bytes

!

! Last configuration change at 07:20:17 PST Tue Jun 9 2009

! NVRAM config last updated at 07:20:32 PST Tue Jun 9 2009

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime localtime

service password-encryption

!

hostname VG224-1

!

boot-start-marker

boot-end-marker

!


!

no aaa new-model

!

resource policy

!

clock timezone PST -8

ip subnet-zero

ip domain name ***

ip name-server ****

ip name-server ****

no ip dhcp use vrf connected

!

!

!

!

voice-card 0

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address ************

duplex full

speed 100

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip default-gateway ***********

ip classless

ip route 0.0.0.0 0.0.0.0 ***********

!

ip http server

!

snmp-server community *********

snmp-server community**********

!

!

control-plane

!

!

voice-port 2/0

!

voice-port 2/1

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

ccm-manager redundant-host ***********

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server **************

ccm-manager config

!

mgcp

mgcp call-agent ********* 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

mgcp default-package fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax rate 12000

no mgcp fax t38 ecm

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

dial-peer voice 99920 pots

service mgcpapp

port 2/0

!

dial-peer voice 999223 pots

service mgcpapp

port 2/23

!

dial-peer voice 99921 pots

service mgcpapp

port 2/1

!

dial-peer voice 99922 pots

service mgcpapp

port 2/2

!

dial-peer voice 99923 pots

service mgcpapp

port 2/3

!

dial-peer voice 99924 pots

service mgcpapp

port 2/4

!

dial-peer voice 99925 pots

service mgcpapp

port 2/5

!

dial-peer voice 99926 pots

service mgcpapp

port 2/6

!

dial-peer voice 99927 pots

service mgcpapp

port 2/7

!

dial-peer voice 99928 pots

service mgcpapp

port 2/8

!

dial-peer voice 99929 pots

service mgcpapp

port 2/9

!

dial-peer voice 999210 pots

service mgcpapp

port 2/10

!

dial-peer voice 999211 pots

service mgcpapp

port 2/11

!

dial-peer voice 999212 pots

service mgcpapp

port 2/12

!

dial-peer voice 999213 pots

service mgcpapp

port 2/13

!

dial-peer voice 999214 pots

service mgcpapp

port 2/14

!

dial-peer voice 999215 pots

service mgcpapp

port 2/15

!

!

line con 0

line aux 0

line vty 0 4

password 7 *************

login

!

ntp clock-period 17179886

ntp server ************

ntp server ***********

end


VG224-1#

NPT_2 Tue, 06/09/2009 - 08:01

The dial peer debug comes back as follows when I try to make a call from a fax machine just gives me dial tone after dialtone:


VG224-1#

Jun 9 15:57:38.876: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Calling Number=, Called Number=, Voice-Interface=0x630D561C,

Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,

Peer Info Type=DIALPEER_INFO_SPEECH

Jun 9 15:57:38.876: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Match Rule=DP_MATCH_PORT;

Jun 9 15:57:38.876: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Result=Success(0) after DP_MATCH_PORT; Incoming Dial-peer=99920

Jun 9 15:57:38.876: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerSPI:[email protected]

VG224-1#

NPT_2 Tue, 06/09/2009 - 09:37

It looks like I have figured it out. I determined that my VG224 was running really old IOS 12.4(2)T5 IOS I updated to 12.4(24)T and everything seems to be working now.

Actions

This Discussion