Sending a call straight to taking a message in Unity

Answered Question
Jun 8th, 2009

I am running Unity 4.0(1) and am trying to send a call from our call center directly into voicemail to leave a message without playing a prompt. I have set the standard greeting to "blank" but it keeps playing a system prompt before going to take the message. What am I missing?

I have this problem too.
0 votes
Correct Answer by James Hawkins about 7 years 6 months ago

Hi,

I have previously solved this problem by using an interview handler with one blank question (just record half a second of silence) that drops the recording in a mailbox.

I sent the the call from the contact center to a CUCM DN configured to forward all calls to Unity.

I then created a Unity call routing rule that matched calls forwarded from the DN and sent them to the interview handler.

This is a bit clunky but was the only way I could find to solve the problem.

Please rate if helpful.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
lindborg Mon, 06/08/2009 - 16:00

Can you be more specific than "a system prompt" here?

First, I'd use the alternate greeting - it overrides all others regardless of schedule so it's always a good idea to do that.

Second, I suspect you're hearing "I'll record your message at the tone..." prompt. This is not the greeting, it's something that plays before every record. On more recent versions (4.0(1) is quite old) of Unity you have the option of turning this off. On older versions you'll have to go in and manually hack the prompts.

If you can verifity exactly what you're hearing we can go from there...

rtrees Tue, 06/09/2009 - 07:36

Sorry, the specific message is "Sorry, extension 1911 is busy or does not answer. You may record your message at the tone when you are finish you may hang up or hold for more options."

Thanks for your help.

Correct Answer
James Hawkins Mon, 06/08/2009 - 21:51

Hi,

I have previously solved this problem by using an interview handler with one blank question (just record half a second of silence) that drops the recording in a mailbox.

I sent the the call from the contact center to a CUCM DN configured to forward all calls to Unity.

I then created a Unity call routing rule that matched calls forwarded from the DN and sent them to the interview handler.

This is a bit clunky but was the only way I could find to solve the problem.

Please rate if helpful.

I can't remember specifically what options are available in the greeting for version 4.0(1), but in version 5, here is what I would do. For the mailbox in question, set the schedule to all hours all days, modify the standard greeting to be "Blank" and then check the box for "Do not play the Record Your Message at the tone prompt". However, I suspect you may not have all these options.

If that is the case, what the gentleman above wrote should work. Instead of using an interview handler, you can also use a standard call handler, and assign the DN to the call handler...this saves creating the call routing rule. Set the schedule to all hours all days and then in the greetings either set it to blank or record a second of silence and set the after greeting option to take message. In messages, select the recipient mailbox or distribution list.

Good luck!

lindborg Tue, 06/09/2009 - 09:24

both the above should work - but note that if you activate the alternate greeting and use that you don't need to worry about what schedule the handler or subscriber is associated with.

The advantage of using an interview handler is you don't need to worry abou the "I'll record your message at the tone..." prompt if you don't want that included since.

rtrees Wed, 06/10/2009 - 09:53

I ended up using the interview handler method. I tried using the call handler but it seemed to do the same thing I was having problems with to begin with.

So, when I get upgraded to the most current version of Unity I should be able to do this with the subscriber itself correct?

Actions

This Discussion