Problem With Sync On Device

Unanswered Question
Jun 8th, 2009
User Badges:

Hi,


I recently made a change to all our switches using a netconfig job. The job was successful so I decided to use the Sync On Device from RME to write and sync all the configs


This seems to have worked for the majority of the devices but 56 of them are being problematic.


It would appear that RME is having problems collecting the VLAN informatation (see attached screenshot). For each device that won't sync RME can collecting the RUNNING and STARTUP config OK but fails on the VLAN. The error says that it couldn't change from USER to ENABLE mode but a user verification report for the failed devices confirms that SNMP, Telnet and Telnet Enable are all "OK" - SHH is disabled so I'm not sure why that's mentioned in the report??


It would also appear that Sync failure causes some kind of change to the config on these switches but I can't see what it is. After the sync job has run on each of the failed devices RME highlights "CONFIG_CHANGE" for each device but clicking on the change to see the diff viewer just shows the login banner section highlighted as red with no obvious changes??


I'm running LMS 3.1 with RME 4.2.1



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 06/09/2009 - 08:29
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

A sniffer trace of all telnet traffic to one failing device when the sync archive job runs will be helpful in tracking down the enable mode problem.


As for the sync issue, this is a known bug, CSCsu99748. It should be fixed in RME 4.2 if you update to all of the recently released RME device packages, then run a sync archive for all previously out of sync devices.

mbhnt Tue, 06/09/2009 - 12:21
User Badges:

Thanks for that..


I downloaded and installed all the most recent RME packages and then run a Sync On Device but the problem is still occuring.


I run the sync on the device but the device immediately appears in the Change Audit as having a "CONFIG_CHANGE". When I click the config change the only red (changed) txt in the config view is the banner and NTP Time Period. The Banner doesn't appear to have changed but the NTP time period has. Not sure why this is getting pickup up though because this configured for exclusion in Archive Mgt??

BlueyVIII Tue, 06/09/2009 - 14:53
User Badges:

OK, on my server I downloaded all the Device Updates, rebooted the server and now the Sync On Device seems to be working.


However, now I have a problem when I click on the "CONFIG_CHANGE" within RME - I get the error in the attached JPG file.


To make sure it was a rogue process after the Device Updates I've stopped & started the Daemon Mgr and even rebooted the server but I keep on getting this error when trying to view the config changes.



Any idea's???



Attachment: 
Joe Clarke Tue, 06/09/2009 - 16:43
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Is this a config change for the VLAN config? What does the row look like?

BlueyVIII Thu, 06/11/2009 - 09:57
User Badges:

Unfortunately I can't tell what the change is because I get the error instead of the config viewer.


To get the error I'm selecting "CONFIG_CHANGE" from within the Change Audit section of the RME Portlet

Joe Clarke Thu, 06/11/2009 - 10:12
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Run a Change Audit standard report under RME > Reports > Report Generator, and try to correlate the portlet record to a record in the Change Audit report. That will help determine the exact type of config change.

BlueyVIII Thu, 06/11/2009 - 10:30
User Badges:

OK, ran the report and found the record.


The message in the report is "Syslog triggered Config Collection : PRIMARY-RUNNING"


When I click on details I get the same error message as in the attachment above "DCMA055:CM0207 Could not get config analyzer implementation for $1 Cause: $2"


I tried clicking the "detail" on the report for other devices and got exactly the same thing.

Joe Clarke Thu, 06/11/2009 - 11:06
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

It sounds like your archive is damaged. The dcmaclient.log may have additional information, but it may require you to remove this device from RME then re-add it to solve the problem.

BlueyVIII Thu, 06/11/2009 - 11:10
User Badges:

I removed the device but the same error keeps occuring for every device..


Do I need to remove and then re-add all 315 devices?? I hope not!

Joe Clarke Thu, 06/11/2009 - 11:22
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I can't say without seeing more information.

BlueyVIII Thu, 06/11/2009 - 11:25
User Badges:

OK...Thanks for your help (again)...


I'll log a TAC case..

BlueyVIII Fri, 06/12/2009 - 11:55
User Badges:

I've got this solved now.


TAC suggested installing Device Updates. While I was doing this I also downloaded and installed DFM 3.1.3.


The problem is now solved and I can see the DiffViewer when I click on CONFIG_CHANGE.

Actions

This Discussion