Application Import Registration Summary error

Unanswered Question
Jun 10th, 2009

When I try to register QPM 4.1.1 in our Ciscoworks LMS 3.1 portal in a multiserver trust I get this message:

Problem with File /WEB-INF/screens/cmic/Application_Registration/Imported_Application_Summary.jsp!!!Getter for property importSummary threw exception: java.util.NoSuchElementException

Does anyone know why? The registration of HUM1.0 worked flawlessly.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Wed, 06/10/2009 - 09:47

This could be related to CSCsm17224, but that should be fixed in QPM 4.1.1. Post the NMSROOT/objects/data/cmf/cmic/mst-templates/qpm.xml from the QPM server as well as the NMSROOT/MDC/tomcat/logs/stdout.log and stderr.log from the server that threw this error.

orsonjoon Wed, 06/10/2009 - 23:33

The strange thing is that in the qpm.xml version 4.1 is mentioned.

While Packages installed

Packages Installed Version With Patch Level Installed Date

QoS Policy Configuration and Monitoring Tool 4.1.1 10 Jun 2009, 13:40:23 CEST

I added the requested attachments.

orsonjoon Fri, 06/12/2009 - 00:10

Sorry, missed that one see attachment.

Another thing what I noticed was this message:

System Identity User Not configured properly for

- (qpm)

In ACS the application was registered properly and the group where the system indentity user is in has all priveliges assigned to it (see attachment). Can't figure out wat is wrong.

Joe Clarke Fri, 06/12/2009 - 08:38

Your ACS setup is wrong. You should have granted Super Admin access to the System Identity User for QPM. System Administrator is not sufficient.

As for the registration problem, I don't see anything wrong in the stderr.log. I recommend you open a TAC service request so they can try and recreate this. I don't have a server with QPM 4.1.1 with which I can test.

orsonjoon Tue, 06/16/2009 - 00:13

The best ACS admin rights I can select in ACS is "System Administrator" (see attachment). It's impossible to select Super Admin access. Are you sure?

Joe Clarke Tue, 06/16/2009 - 08:46

Then you need to create a custom Super Admin role for QPM. Make sure all of the task boxes are checked. Then you can assign that role for your System Identity User.

t.kraemer Sun, 07/12/2009 - 23:23

Hi jclarke,

I got exaclty the same error message running QPM 4.1.1 and LMS 3.1, too. In my case, I'm using CiscoWorks local authentication without ACS integration.

DCR replication and single sign-on works fine.




This Discussion