basic outputdrop cat4500 sup6-e

Unanswered Question
Jun 10th, 2009

hello,

on a cat4500 sup6-e switch with WS-X4648-RJ45V-E card,

we have some output drops (giga and so 100M speed's interfaces).

the default number of output queue is 40.

Can we rise to 50 (or 60) ?

is there a commande like the 'hold-queue' one ?

I know that speed adtation between Giga links and 100M link can be an issue.

The flow dropped isn't yet find/known.

sh int gi 2/21

...

Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000-TX

....

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 224019085

Queueing strategy: fifo

Output queue: 0/40 (size/max)

....

Regards,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rico_hao40 Wed, 06/10/2009 - 07:17

you can try set both side hard-code full duplex/100M , do not use auto

jabouaf Wed, 06/10/2009 - 07:37

Hello,

it doesn't seem to be a duplex mismatch.

The drops increase meanly in the morning and in the afternoon.

rehards,

J.David

sachinraja Wed, 06/10/2009 - 08:06

Hello David

Output drops are just due to congestion or sudden burst of traffic on that interface, and the outgoing interface cannot accept all packets that should be sent out. Easiest way to avoid output drops, is to increase the line speed.. since it isnt a duplex issue, i dont see any other means by which you can control this, except applying QOS..

queue size can be changed, but it isnt really recommended, as it can timeout geniune tcp handshakes.. This is what I found on CCO:

"Never increase the output queue in an attempt to prevent output drops. If packets stay too long in the output queue, TCP timers can expire and trigger retransmission. Retransmitted packets only congest the outgoing interface even more."

Give it a shot with QOS, if you have the matrix of applications on the network..

Hope this helps.. all the best.. rate replies if found useful.

Raj

jabouaf Wed, 06/10/2009 - 08:44

hello,

Raj,

We do not have the matrix of applications on the network, so QoS can't be used.

Increase of line speed can't be done at the moment.

Some links are connected to servers with giga links. Maybe we can try using the flowcontrol options.

Some others links are connected to cat3750 and cat2950 or cat2960 but flowncontrol seems to not bee available (I have to check this anyway).

In the mean time how can we increase those buffers ? I known that this is not recommended.

Regards,

J-David

sachinraja Wed, 06/10/2009 - 09:23

Hello David

To limit the size of the IP output queue on an interface, use the hold-queue command in interface configuration mode. To restore the default values, use the no form of this command.

hold-queue length {in | out}

out specifies the output queue.. The default is 40 packets. For asynchronous interfaces, the default is 10 packets.

Hope this helps.. all the best.

Raj

jabouaf Wed, 06/10/2009 - 09:36

hello Raj,

in fact this command seems to not be available on this cat4500 because of the supervisory or the line card (or because it is a switch ?).

I'll have a look too at the "flowcontrol" feature if this can be used on some link giga (to some servers).

We have some cat3750 connected to the cat4500, but the used of the flowcontrol feature seems to not be good as the cat3750 can't send pause frame.

Regards,

J.David

sachinraja Wed, 06/10/2009 - 09:46

David

I think flowcontrol is an option for receive buffer, and not output queues.. ill have to check more on this... you need to enable it both the ends, to make sure the switch sends pause frames to the opposite switch when the receive buffer becomes full.. are you also seeing input queue drops on the interface?

Hope this helps.

Raj

Joseph W. Doherty Wed, 06/10/2009 - 09:42

"is there a commande like the 'hold-queue' one ? "

For a 6E and 12.2(44)SG (or later), the answer appears to be yes.

See: http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/52sg/command/reference/int_sess.html#wp2339887

PS:

Regarding Raj's Cisco quote (from http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a0080094791.shtml ?), I don't agree with Cisco's statement (I believe it's an over simplification), but increasing queue depth, when dealing with oversubscription, is often counter productive. You might want to try DBL.

Actions

This Discussion