Output drops.

Unanswered Question

Hello all,


I have a Frame-relay DS3 connected to another router which I do have control over that is dropping packets. It's setup with FRTS with QoS. The drop count on "Total output drop" from the "show interface" command seems to correspond to the "late-dropped out pkts" from the "show frame-relay pvc" command. The odd thing is there is another DS3 setup exactly the same way and same hardware, and transmits more bandwidth but drops are no where near. Could someone shed some light on this issue?


PVC Statistics for interface Serial1/0 (Frame Relay DTE)


Active Inactive Deleted Static

Local 1 1 1 0

Switched 0 0 0 0

Unused 0 0 0 0


DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.100


input pkts 339 output pkts 17372275 in bytes 24739

out bytes 1830159470 dropped pkts 2964 in pkts dropped 0

out pkts dropped 2964 out bytes dropped 1778392

late-dropped out pkts 2964 late-dropped out bytes 1778392

in FECN pkts 0 in BECN pkts 0 out FECN pkts 0

out BECN pkts 0 in DE pkts 0 out DE pkts 0

out bcast pkts 1013 out bcast bytes 86661

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 11427000 bits/sec, 4079 packets/sec

Shaping adapts to BECN

pvc create time 1y10w, last time pvc status changed 21w3d

ar2.lsanca#show int s1/0

Serial1/0 is up, line protocol is up

Hardware is PA-MC-2T3-EC

Description: **omitted**

MTU 4470 bytes, BW 44210 Kbit, DLY 200 usec,

reliability 255/255, txload 76/255, rxload 1/255

Encapsulation FRAME-RELAY IETF, crc 16, loopback not set

Keepalive set (10 sec)

LMI enq sent 413, LMI stat recvd 413, LMI upd recvd 0, DTE LMI up

LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0

LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE segmentation inactive

FR SVC disabled, LAPF state down

Broadcast queue 0/256, broadcasts sent/dropped 1014/0, interface broadcasts 945

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 01:08:53

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 2964

Queueing strategy: fifo

Output queue: 3/40 (size/max)

30 second input rate 0 bits/sec, 0 packets/sec

30 second output rate 13227000 bits/sec, 4216 packets/sec

754 packets input, 31358 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 parity

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

17387951 packets output, 1971927914 bytes, 0 underruns

0 output errors, 0 applique, 0 interface resets

0 output buffer failures, 0 output


policy-map qos-ds3

class real-time

priority percent 23

set mpls experimental topmost 6

set ip precedence 6

class business

bandwidth percent 55

set mpls experimental topmost 2

set ip precedence 2

class class-default

bandwidth percent 22

set mpls experimental topmost 0

set ip precedence 0


map-class frame-relay qos-to-gc

frame-relay cir in 56000

frame-relay cir out 45000000

frame-relay mincir 45000000

frame-relay adaptive-shaping becn

service-policy output qos-ds3


interface Serial1/0

no ip address

ip pim sparse-dense-mode

encapsulation frame-relay IETF

load-interval 30

mpls ip

no dsu remote accept

dsu bandwidth 44210

framing c-bit

cablelength 224

frame-relay traffic-shaping

max-reserved-bandwidth 100

!

interface Serial1/0.100 point-to-point

description Option B

ip address x.x.x.x 255.255.255.252

snmp trap link-status

mpls ip

frame-relay class qos-to-gc

frame-relay interface-dlci 100

service-policy input remark-label-gc




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Wed, 06/10/2009 - 14:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, likely the systems connected to the other networks do not generate traffic bursts like the ones in subject.


In any case the percentage of dropped packets is very small so you should not have any problem.


Joseph W. Doherty Wed, 06/10/2009 - 17:15
User Badges:
  • Super Bronze, 10000 points or more

" Is the only way to resolve this is to add more bandwidth? "


Assuming some packet dropping is acceptable, active queue management is an alternative.

Paolo Bevilacqua Wed, 06/10/2009 - 21:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Try tuning up your CIR parameters a little.

Often a FR network can carry more than the contractual value.

Actions

This Discussion